x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Receives Decals desaturates the Base Color

as you can see on the attached files the texture gets desaturated if the receive decals attribute is turn on.. and if it of the decals aren't working anymore (obviously...) the textures guys in our team are going crazy because they just dont get the result of the textures they are see in Photoshop. we are working on a flat, saturated look and with this problem it is super hard to get the textures working correctly is there a workaround?? i dont want to give up the decals but its also shitty to add all textures in two variants...

FYI i added this: r.EarlyZPassMovable=1 r.EarlyZPass=2 r.DBuffer=1 into the BaseEngine.ini under [SystemSettings]

alt text

Product Version: Not Selected
Tags:
decal_prob1.jpg (304.2 kB)
decal_prob2.jpg (294.0 kB)
more ▼

asked Aug 29 '14 at 06:22 PM in Rendering

avatar image

DarknesZ
114 10 15 19

avatar image Lovecraft_K ♦♦ STAFF Aug 29 '14 at 03:42 PM

Hey DarknesZ -

If I am reading you question correctly, you want to set the Decal Blend Method to Stain.

Thank You

Eric Ketchum

avatar image DarknesZ Aug 29 '14 at 05:57 PM

hey eric, no i dont wont to switch the decal blend mode nor dosnt have to to with decal. it because of the object (static mesh, bsp ) and/or the material. if you deactivate on an object the receives decal attribute cou can see that the object gets slightly darker and more saturated. this it the correct look of the material / texture i want to achieve. but i want this look with the ability to use decals...

avatar image Lovecraft_K ♦♦ STAFF Aug 29 '14 at 07:22 PM

Hey DarknesZ -

Obviously I did in fact read your question incorrectly, but now that I see what you are asking I am beginning to look into this issue for you. May I ask, what is the roughness setting on the Brickwall in your example photos?

Thank You

Eric Ketchum

avatar image DarknesZ Aug 29 '14 at 07:48 PM

its the wall out off the content example project, the decals map... i tested it with different roughnes spec and metal values no change, but here at home i dont have this issue but i have not the decal tweak in the setting...(r.EarlyZPassMovable=1 r.EarlyZPass=2 r.DBuffer=1 into the BaseEngine.ini under [SystemSettings]) i will test it again with the tweak tomorrow...

thanks for you help

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hey DarknesZ -

You will have to change the Decal Blend Mode to one of the DBuffer settings (a good default one is Translucent, Color, Normal Roughness) which will give you access to the DBuffer which you have turned on with the above BaseEngine.ini variables.

Here is the example of the same setup with a DBuffer Decal:

alt text

dbuffer.jpg (169.8 kB)
more ▼

answered Sep 26 '14 at 03:48 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.6k 703 260 737

avatar image DarknesZ Sep 26 '14 at 06:50 PM

big thx!! it working! but one last questions, is it possible to get the emissive channel to work with the dbuffer options?

avatar image Lovecraft_K ♦♦ STAFF Sep 26 '14 at 09:16 PM

Hey DarknesZ -

The way that the DBuffer works with the Lighting in the level currently restricts the use of the Emissive channel, but DBuffer is a work in progress so I can let our engineers know that we have a user requesting it.

For the time being though you would have to use the none DBuffer Emissive Decal.

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

OK it Seems to be fixed in the 4.4.1 version at home with and without the BaseEngine.ini Tweak. i will keep you up to date, after we switche our work ue to 4.4.1..

more ▼

answered Sep 01 '14 at 08:22 AM

avatar image

DarknesZ
114 10 15 19

avatar image Lovecraft_K ♦♦ STAFF Sep 02 '14 at 05:10 PM

Hey DarknesZ -

Make sure when you test you remove Eye Adaptation for the best test results, as any change in coloring like that will trigger the Auto Exposure feature in the Post Process.

Thank You

Eric Ketchum

avatar image DarknesZ Sep 02 '14 at 05:29 PM

mmh interesting approach.. but this is not the reason. at the work project is Auto Exposure disabled.. as soon as we update our editor i will present you the outcome..

avatar image DarknesZ Sep 25 '14 at 05:26 PM

ok finally we updated our engine and the issue is gone!!! but its decals still need a direct light to work property, if the light is not bright enough the decal is fading away...

and the tweak ( r.EarlyZPassMovable=1 r.EarlyZPass=2 r.DBuffer=1) i not also not helping!!

i cant imagine way decals should work like this ..

avatar image Lovecraft_K ♦♦ STAFF Sep 25 '14 at 05:29 PM

Hey DarknessZ -

Could you post a screenshot of your Decal Material Setup or a test version that is behaving the same way? I want to look into this further but I want to be jumping off the same point as you are.

Thank You

Eric Ketchum

avatar image DarknesZ Sep 25 '14 at 08:23 PM

here is a screenshot.. its out of the content examples project ,the decal map,its 1.1 basic decal...

as you can see, i just set the pointlight intensity from 5 to 0. and the decal get "transparent"

alt text

untitled-1.jpg (1.1 MB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question