x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Fade out Particle Emitter Spawn Rate via Blueprint

Hi there, I'm not getting some fundamental aspect of assigning values to Particle Emitters (and probably other objects, too). I've created a pretty nice looking particle system that activates and positions itself when the left mouse button is pressed. When Released, I used to just destroy the emitter and, while that was OK, I'd prefer to have the particles fade out prior to destroying the emitter. I've created a timeline that nicely fades from 40 to 0 when the LMB is released in .5 seconds -- I added a print function to confirm at one point -- but I'm not getting how to apply that value to the particle's spawn rate or instanced parameter. Any suggestions are greatly appreciated. alt text

Product Version: Not Selected
Tags:
mouseparticles.png (243.2 kB)
more ▼

asked Aug 30 '14 at 05:58 AM in Blueprint Scripting

avatar image

GrayHulk
52 8 7 14

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

There are a couple of steps that need to be taken:

Firstly, you need to set the spawn rate scale in cascade to a float parameter. (Specifically, distributionFloatParticleParameter). Then, in your blueprint, you need to use "Set Float Parameter" for the particle system, and pass in the name of the parameter defined in cascade. See attached for details.

alt text

alt text

more ▼

answered Aug 30 '14 at 10:36 AM

avatar image

veggiesaurus
529 20 21 61

avatar image [Epic]homeRye STAFF Sep 07 '14 at 04:38 AM

you can also just use a deactivate on your particle system. If you destroy your emitter it removes the effect and your particles pop out. If you deactivate the emitter it waits for the particles to finish their lifetime, and then cleans up the emitter.

avatar image veggiesaurus Sep 09 '14 at 07:02 AM

That does seem like an easier solution to the OP's issue, although he should probably learn about parameters anyway! :)

avatar image JZed_JPI Aug 02 '16 at 05:47 PM

Might this solution broken in UE 4.12.5? I can't seem to expose any parameters that are floats (both Spawn Rate and Rate Scale) but Initial Velocity works as documented. Anyone else seeing this?

avatar image lukefwilson Aug 30 '16 at 08:56 AM

I'm getting unexpected behavior in 4.12.5 too. Problem: I can set the spawn rate to 0, but then can't reset it back to 1 later.

avatar image acej0k3r Sep 28 '18 at 10:27 AM

The way you do this is you can reference your particle system like shown above call spawn float parameter on it and then make sure the parameter name is exactly how you typed it in the particle, and also MAKE SURE YOUR MIN VALUE and MAX VALUES are optimized correctly if you want a range between min 0 - max 7500 particles then you can increase from 0 to 7500 or decrease from 7500 to 0 particles using lerp or timeline or any other methods of incremented values or decremented values.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question