x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

OpenLevel "crashes" Editor, but not with every level

Hi there!

My colleagues and I encountered a problem recently that we can't seem to figure out.

At the end of our levels, we call a method in Blueprint that will launch the next level using the Open Level Node. Some levels do open correctly, and other levels just never open...

Here's what the exec looks like: alt text So depending on the level we're currently in, we load the next level. Yes, all Level Name has been written correctly.

The only working transitions are between 1A_P & 1B_P and 3_P & 4_P. Any other transitions does not work.

We tried loading these levels through the Main Menu, and the same levels don't load. We thought it could be only because the levels are heavy and long to load, but UE4 is not responding and it is impossible to press Stop: we have to shut down UE4 by force. It's the same problem both in Viewport and PIE. alt text

When debugging, we put breakpoints on the Open Level nodes: the flow did reach the node, so the problem is not before that (nor the GetCurrentLevelName nor the Switch).

We just can't seem to figure what's going on. Does anybody have a clue?

Product Version: UE 4.22
Tags:
more ▼

asked Aug 02 '19 at 01:28 PM in Blueprint Scripting

avatar image

Rocorneau
31 1 2

avatar image Xyah_ Aug 02 '19 at 01:47 PM

Hey there,

How long did you wait while UE4 Editor was stuck opening the levels?

Have you opened these levels in the editor to check that all the shaders been compiled for the level?

If you package the game, does this occur there as well?

avatar image Rocorneau Aug 02 '19 at 02:15 PM

Hi, We waited around 10 minutes and nothing moved. We did the same with the logs open to see if something was really loading or not, and no log is written after a certain point (no more logs 30 sec after the OpenLevel node is hit)

We open these levels in the editor daily. We're in blocking phase and have close to no shader, so this can't be the problem.

We haven't try packaging the game yet. If we do in the next weeks I'll keep you guys updated.

avatar image Xyah_ Aug 02 '19 at 02:34 PM

Yep, Open Level is a blocking operation, UE4 will freeze completely until the level has been completely loaded. You can try using Level Streaming (https://docs.unrealengine.com/en-US/Engine/LevelStreaming/index.html) which is non-blocking (and aimed for Open World). But, just to test, see if these maps do get loaded using this method. I prefer this method over Open level because you can add animations to the loading screens! Although there are some cases (e.g. Multiplayer) where Open Level is absolutely necessary.

EDIT: Also, if the maps do get too big, you should use level streaming to load only the parts of the maps you want the character to see and unload parts of the maps (e.g. caves) that will not be necessary for a while!

avatar image Rocorneau Aug 02 '19 at 03:53 PM

Hi, thanks for your answer!

I don't think we want to use Level Streaming to pass from one map to the other. We already use Streaming methods for the inside of our levels, which have a bunch of streaming level each to fit our workflow. Streaming between our 7 main Maps would be hell as we would have to handle streaming on 100+ levels.

I'm still keeping your idea in case we absolutely find nothing to carry on, but I feel like it will be awfull to handle 100+ levels at once. It doesn't seem to fit with the kind of project we are currently working on.

Thank you anyway!

avatar image danielf94 Aug 02 '19 at 02:07 PM

Hi, did you try to open the levels from the editor and hit play?

verify this for all levels

avatar image Rocorneau Aug 02 '19 at 02:12 PM

Yes, and it works.

avatar image Rocorneau Aug 08 '19 at 07:00 PM

Hi! We are still stuck with our problematic even though we tried different things if someone has a clue your help would be amazing!

Today transition between Stage 4 and 5 worked but we still don't know why. We are currently trying to figure out what we did differently in order to come to an answer.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

try something, at its main level in the level blueprint use open level and write the name of the levels try this for each level separately, if you do not give an error then some error has its code.

more ▼

answered Aug 02 '19 at 02:24 PM

avatar image

danielf94
173 5 8 9

avatar image Rocorneau Aug 02 '19 at 02:32 PM

I didn't try for each yet, but I did set the Open Level node on a keybind to try if the problem was from the normal flow of the level (Ending cutscene -> Then Open) or simply from trying to open the Level and it didn't work any better. I can try with each if you'd like, but I highly expect the same result.

avatar image danielf94 Aug 02 '19 at 02:59 PM

I don't know if this can help you, but I have solved several bugs in this way

make a backup of your project, now delete the following folders:

Binaries, Intermediate and Saved.

and rebuild your project files by opening your .uproject file, a message will appear and click on "yes"

avatar image Rocorneau Aug 02 '19 at 03:52 PM

Hi, We've done that a bunch for other reasons. Didn't change a thing.

Thank you anyway!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question