x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

No Cast to X show up but already is in BP HELP!

alt text

Can some please help! I cannot find any help online, I already tried restarting Engine, deleting all save files from project but no Custom Anim Blueprints show up ever, even though in the example VR Project the Controller BP already has a Cast to RightHand_AnimBP and it works fine but I am unable to use any other anim blueprints. And if I were to accidentally delete the "Cast To RightHand..." then I would not be able to get it back!

I am unable to get any progress on my Animations please I really need help!

Product Version: UE 4.23 Preview
Tags:
screenshot-18.png (92.2 kB)
more ▼

asked Aug 04 '19 at 03:29 PM in Blueprint Scripting

avatar image

Rolandem
21 8 8 14

avatar image ppchavan001 Aug 06 '19 at 10:12 PM

it should be there,
what file are you trying to cast to? can you see the file in the content browser? tip : learn source control/ source tree

avatar image Rolandem Aug 06 '19 at 10:19 PM

I cannot cast to any blueprints that are not default ones, not even the Cast To RightHand_AnimBP that was already in this BP from the default VR Project (as you can see in the screenshot). Will look into source control/tree though!

avatar image DonBusso Aug 06 '19 at 10:30 PM

It matters where you drag off from, just try dragging from out from somewhere else or untick content sensitive.

avatar image Rolandem Aug 07 '19 at 12:40 PM

I tried different blueprints, 20 different things/places to drag off, tried turning the context sensitivity on/off and tried just right clicking in empty space, but nothing.

avatar image ppchavan001 Aug 07 '19 at 12:47 PM

strange,
i guess then you would need to copy-paste that node every time

avatar image Rolandem Aug 07 '19 at 11:26 PM

Thats what I do now, but I am unable to use any other animation blueprints for other meshes.

avatar image Zack.Henderson ♦♦ STAFF Aug 08 '19 at 07:29 PM

Hello Rolandem,

This actually looks like a bug. We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue. https://epicsupport.force.com/unrealengine/s/

From, Zack Henderson

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi,

I can just confirm that this problem exists also for me (version 4.23 P5).

Edit: Just tested with version 4.22.3 and it is working like expected. Cheers

more ▼

answered Aug 12 '19 at 05:57 PM

avatar image

Markus68er
26 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question