x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Suddenly Can't Capture a Movie From Camera

I've got a level sequence set up with multiple cameras. I'm using the Camera Cuts track to cut between cameras and I've properly extended each shot for the full length of the frames I need to capture. I've got the custom animation start and end frames set correctly as well.

When I hit Play to preview the sequence, it loads up Pie and shows a random place on the map where there's no camera (or anything, for that matter). When I hit Capture Movie in the Render Movie Settings it brings up a window with the same view and records that. I can't seem to get it to recognize my cameras.

The worst part is I've been successfully rendering out image sequences for a couple weeks now from these cameras and sequences for weeks now, and I just loaded it up to render more. I must have deleted something by accident, or did something wrong, because everything that was working well, isn't anymore. What should I have in place for this to all work properly, because it was just an hour ago?

Product Version: UE 4.22
Tags:
more ▼

asked Aug 11 '19 at 11:09 PM in Rendering

avatar image

oWH_HPo
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Sometimes all it takes is finally giving up and posting on the forums to solve it. I solved it: select the sequence in the world outliner, look for Playback in the Details panel, and make sure Auto Play is checked off. Otherwise it won't play on load.

more ▼

answered Aug 12 '19 at 01:07 PM

avatar image

oWH_HPo
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

How are you playing the sequence? Is it on autoplay (there's a checkbox on the level sequence actor to enable this)? Or is there a level blueprint node that plays the sequence? It's probably not that though because when you render the movie from the sequencer button, it should force the sequence to play.

Can you see if other elements are playing in the sequence? Maybe just throw in a quick fade track, animate it, PIE and see if it fades the PIE window. If it does play, then maybe the camera bindings somehow got broken - do the camera cut track sections show the names of the correct cameras it's supposed to switch to? Maybe you could try to recreate your camera cut track.

If all that doesn't help, maybe post a picture of your sequence in case someone can spot what's wrong.

PS - It's good you mentioned that it doesn't work in PIE. That's the first thing I would have asked.

more ▼

answered Aug 12 '19 at 06:36 AM

avatar image

Max.Chen STAFF
2.3k 28 14 69

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question