x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Set array elem suddenly stopped working ?

My set array elem node suddenly stopped working. I did a little research and found that this is a bug. But that answers were old. Is there any solution to this ?

alt text

Product Version: UE 4.21
Tags:
capture.png (475.2 kB)
more ▼

asked Aug 13 '19 at 11:36 AM in Using UE4

avatar image

AmazingChicken
21 1 3 4

avatar image SpynderMK 6 days ago

What do you mean by "Suddenly stopped working"? When it stopped working? What have you done before this? Is node not fire or node fire but doesn't do anything?

avatar image AmazingChicken 6 days ago

I didn't make any changes to my mission accept logic. Event and node is firing fine, I put a print string in before and after set array elem node, it printed fine. But node itself doesnt change any values in array. A few minutes ago node was working fine.

avatar image SpynderMK 6 days ago

is it working with other arrays and other structs? Are you playing as client or standalone game (Possible replication problem)? Also it'll be good to check logs (Window -> Developer Tools -> Output Logs)

avatar image AmazingChicken 6 days ago

Thanks a lot for your time. Logs give me the source of error. Although I was resizing my array on begin play in mission bp, objective array didn't get resized for some reason. I added a resize node on event accept mission and it did the trick. I still have no idea why it worked before and didn't give me this error days ago.

avatar image SpynderMK 6 days ago

it'll be nice if you tick your answer as solved

avatar image ClockworkOcean 6 days ago

I notice you don't have 'size to fit' checked, in your example the SetArrayElem will only work if the array already has at least one item...

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

0 answers: sort voted first
Be the first one to answer this question
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question