x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

AnswerHub Maintenance

Background maintenance is scheduled to occur between 9 - 11am EDT on Tuesday, May 21. Site operation may be slower than normal during this time and a brief interruption in operation may be observed

Errors building 4.4 engine code

Hey guys,

I am trying to build the 4.4 engine code but I am having the following errors pop up on me (See Attached...) alt text

I do not have an occulus rift, but I assume the issue is because of error "cannot open input file 'libovr64.lib'". First I tried to build from my old repo that was updated to 4.4 from 4.2, but that failed with the same error. Since I had not actually made any changes (just studying code), following the instructions I created a new fork, cloned, installed required files (downloaded this morning), but I still receive the same errors. I am building with "Development Editor" and "Win64". I have had the code build properly for me the last time I tried, but I also re-downloaded the DirectX Runtime and re-installed just to be safe.

The only other thing I have done is updated Visual Studio to the new Update 4 CTP 1 update (after reading about the nice performance increases! ).

Any ideas on what might be causing this?

Product Version: Not Selected
Tags:
builderrors2.png (19.9 kB)
more ▼

asked Sep 03 '14 at 10:33 PM in Installation & Setup

avatar image

DotCam
3.1k 74 34 147

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi DotCam,

Unfortunately we missed including the latest Oculus library in the dependencies for 4.4, even though the Engine source code requires it. You can get the necessary files directly from Oculus here. Just extract the zipped file to the root folder of your Engine installation and everything should drop into place.

more ▼

answered Sep 04 '14 at 02:33 PM

avatar image DotCam Sep 04 '14 at 11:12 PM

Thank you Tim!

My build just completed without any errors :)

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question