x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Possible to copy engine from one machine to another?

Platform: Mac Engine 4.4.1

We have relatively slow internet and the 2GB download takes a long time. I copied the engine from shared/UnrealEngine/4.4 and put it on a shared drive. Another subscriber then copied the engine from the shared drive to shared/UnrealEngine/4.4

However when I launch the installer it still wants to download the engine again. We've started the download now but is it possible to simply copy the engine between machines without the install?

Product Version: Not Selected
Tags:
more ▼

asked Sep 04 '14 at 08:43 AM in Installation & Setup

avatar image

PompeyPaul
169 19 21 27

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

[EDIT]
The Launcher will now auto-detect an install copied to the correct place, when attempting a new engine install. No need to manually create the $movedMarker. Make sure you are not attempting this after already starting an engine install on the machine (you can use the Launcher Library to remove it first in this case before attempting)

---- Original message ----

Hi PompeyPaul,

Currently the Launcher won't automatically detect a copied install of the engine, but you can get it to do so with a little trick. You need to create an empty file named $movedMarker, so that you end up with

/Users/Shared/UnrealEngine/4.4/$movedMarker

If you have the engine in the right place, with that file there, then when you click the download button for 4.4, it will cause the Launcher to start right off with the "Verifying" stage, and it would only download something if it found a file that was corrupt or missing.

Let me know how you get on :)
Leigh

more ▼

answered Sep 04 '14 at 08:52 AM

avatar image

leighswift STAFF
1.8k 38 136 42

avatar image PompeyPaul Sep 04 '14 at 09:30 AM

This seemed to work. It went to verify, then it went to Download and downloaded very quickly (added 1% a second), so I think it thought it was downloading. Awesome trick though, thanks!

avatar image leighswift STAFF Sep 04 '14 at 09:57 AM

Interesting.. It's possible that it did just find a missing / broken file and simply downloaded just that. Did it verify a second time after the quick download? I'd be intrigued to see your log for this if you don't mind. Glad it's worked though! :)

avatar image PompeyPaul Sep 04 '14 at 10:02 AM

Where do I get the log from? It's on an artist machine but could grab it.

avatar image leighswift STAFF Sep 04 '14 at 10:13 AM

Oops yea would have helped if i said :). You can find them here:-

[EDIT] Latest log location
~/Library/Logs/Unreal Engine/EpicGamesLauncher/

Probably easiest to just compress the folder up and attach

avatar image CBRherms Mar 18 '15 at 11:31 AM

Doesn't appear to be working any more with EpicGamesLauncher 2.0.1 and UE4.7.3

Have tried a $movedMarker file in both the 4.7 folder and the build folder within that. It's started verifying and in the process of that deleted it deleted the $movedMarker files then started downloading from scratch

Any idea how Best to go about this as i have 70 Macs to update/install this on and only a 20Mb line and WiFi to attempt to do this on. xD

avatar image leighswift STAFF Mar 26 '15 at 10:37 AM

If you saw "Verifying" then that indicates that the marker was correctly picked up. The process you describe indicates that the verifying stage did not find the files it expected, which could be a result of either, the engine you copied was not the latest version being installed, or the files were not copied to the exact location expected.

The log files produced will indicate lists of files that failed to verify which may help see what the issue is for you.

Have you made sure that you have downloaded the latest version one machine, and you are copying the correct new install from there to the other machines?

P.S. the $movedMarker is no longer required in the latest Launcher (2.0.1). You just need to have the engine in the right place and it will detect it automatically assuming it is a fresh install of that engine (no previous unfinished attempts on the machine)

avatar image TJ V ♦♦ STAFF Mar 31 '15 at 06:18 PM

Hi CBRherms,

We haven't heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you're still experiencing this issue, please try Swifty's suggestions and post back here with your results.

Cheers,

TJ

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question