x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[Bug] Static Shadows from Masked Materials

Casting static shadows from a Blend Mode Masked material does not take into account the alpha I tried using both stationary and static point lights and building on production and preview.

alt text

Product Version: Not Selected
Tags:
maskedshadow.png (391.3 kB)
more ▼

asked Mar 11 '14 at 04:29 AM in Rendering

avatar image

ue4-archive ♦♦ STAFF
49.9k 3667 1996 9121

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

This was a bug and is fixed now. Thanks for pointing it out. In the meanwhile, you can work around by simply hooking up your opacity mask connection to the opacity input as well. It won't have any effect on the main rendering (masked uses opacitymask, not opacity) but it will trick the lightmass exporter into doing the right thing.

more ▼

answered Mar 11 '14 at 04:29 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3667 1996 9121

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You can cast shadows based on the material opacity by enabling the setting "Cast Shadow as Masked" inside the properties of your material :

alt text

more ▼

answered Mar 11 '14 at 04:29 AM

avatar image

ue4-archive ♦♦ STAFF
49.9k 3667 1996 9121

avatar image ue4-archive ♦♦ STAFF Mar 11 '14 at 04:29 AM

I tried that and it still didn't work. Same results as the screenshot. I think its broken, I'll add the bug tag.

If i change the material to blend mode translucent and turn on the Cast shadow as masked I get the proper static shadowing.

alt text

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question