x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

HTML5 Build __cxa_demangle symbol multiply defined

When I try to package HTML5 content, I get this linker error from emscripten:

 MainFrameActions: Packaging (HTML5): UnrealBuildTool: C:/Program Files/Emscripten/clang/e1.22.0_64bit\llvm-link: link error in 'C:\Users\Robert\.emscripten_cache\libcxxabi.bc': Linking globals named '__cxa_demangle': symbol multiply defined!

 MainFrameActions: Packaging (HTML5): UnrealBuildTool: Traceback (most recent call last):

 MainFrameActions: Packaging (HTML5): UnrealBuildTool:   File "C:\Program Files\Emscripten\emscripten\1.22.0\emcc", line 1554, in <module>

 MainFrameActions: Packaging (HTML5): UnrealBuildTool:     shared.Building.link(linker_inputs, in_temp(target_basename + '.bc'), force_archive_contents=len([temp for i, temp in temp_files if not temp.endswith(STATICLIB_ENDINGS)]) == 0)

I've tried to build it from 4.4.1, 4.4.2 (4.4 branch) and 4.5 (master branch) but I haven't got it working yet. I've also tried different projects. This particular project was based on the Code Flyer template.

Product Version: Not Selected
Tags:
more ▼

asked Sep 07 '14 at 07:48 AM in Packaging & Deployment

avatar image

smilingrob
570 19 31 49

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

First, I don't think the recommended sdk is 1.22, it is 1.21. That being said - if you want to compile with 1.22 you need a patch. Araxis Merge Patch

If you end up downgrading your sdk - make sure you do it cleanly ( remove older first ) - env var are not set correctly if you downgrade.

more ▼

answered Sep 07 '14 at 06:42 PM

avatar image

[Ankitkk] STAFF
481 13 3 9

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question