x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why are my shadows behaving weirdly?

I'm following the tutorial for time of day minus the skydome blueprint but my shadows are behaving really strangely

alt text

As you can see, some objects aren't casting shadows at all and none of the shadows look right in the slightest for the scene. On top of that as the light moves smoothly along the shadows jump all over the place, even back and forth, which is extremely odd. I've tried changing a bunch of settings around, building the scene at all the various qualities of lighting, and so on but I can't seem to get it to look right.

Product Version: Not Selected
Tags:
more ▼

asked Sep 09 '14 at 05:04 AM in Rendering

avatar image

Elspin
26 2 4

avatar image Lovecraft_K ♦♦ STAFF Sep 09 '14 at 07:13 PM

Hey Elspin -

Ok so first are you using the LPV (Light Propagation Volume) mentioned in the tutorial? Also, what is the lightmap resolution of the ground assets you have in the level and have you set your directional light to movable as its mobility?

Let me know -

Eric Ketchum

avatar image Elspin Sep 09 '14 at 08:11 PM

The lightmap resolution of the floor is 32, but it still happened at 128. The lightmap resolution is 32 for everything else that has one. I'm not using a light propogation volume, but it wasn't mentioned anywhere in the tutorial. My directional light is set as movable, and it's set to not cast static shadows.

The only other thing that I can tell is different from the tutorial is I am lacking a "skydome blueprint" because I can't seem to figure out where that comes from

avatar image Lovecraft_K ♦♦ STAFF Sep 09 '14 at 08:21 PM

Hey -

Well I can clear up the Blueprint issue for you real quick. In your content browser, under View Options (lower right hand corner), check show Engine Content to true. You should now see an Engine Folder immediately above your Game folder. Click on it and run a filter search for "Sky", the BP_Sky_Sphere, should be the first thing that pops up.

Just so we are on the same page, can you post a link to the Day/Night Cycle Tutorial that you are using, I want to make sure I am following exactly what you have.

Thanks -

Eric Ketchum

avatar image Elspin Sep 09 '14 at 10:08 PM

Alright, I've got a BP_Sky_Sphere in and my blueprint and level is basically matched exactly to the tutorial (here's the one I'm following by the way https://wiki.unrealengine.com/Tutorial:_Time_of_Day ), it's just 2 pillars a floor and the level blueprint controlling things. The sky certainly looks nicer now, which is great, but the shadows still look like the sun is teleporting unfortunately. In the interest of making it as clear as possible what's happening, I made a quick video of what's happening https://www.youtube.com/watch?v=b_-95Jxk87o

avatar image Lovecraft_K ♦♦ STAFF Sep 10 '14 at 05:48 PM

Hey Elspin -

Can you post a screenshot of your Level Blueprint? I reproduced the tutorial and haven't find any bugs like you are experiencing. Also do you have any scalability settings changed in the editor?

Thank You

Eric Ketchum

avatar image Elspin Sep 11 '14 at 04:27 AM

I have no idea what scalability settings are, I found them but I certainly haven't changed them intentionally - they appear to all be at 50%/medium. My flowchart is here but it's basically identical as far as I can tell http://i143.photobucket.com/albums/r160/Elspin/daynightblueprint_zpsfd6863d4.png

avatar image Elspin Sep 11 '14 at 04:35 AM

Just out of curiosity I tried to do the tutorial again with a fresh map - exactly the same problem, no change.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hey Elspin -

Change the Scalability Settings under Quick Settings >> Engine Scalability Settings >> Select Epic, and rebuild lighting. Does that fix your shadows?

Thank You

Eric Ketchum

more ▼

answered Sep 11 '14 at 01:19 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 702 260 736

avatar image Elspin Sep 11 '14 at 02:54 PM

Fixed! It's finally sorted out, the shadows look like they should and they no longer jump back and forth. Thanks for all the help, I just wanted to say I really appreciate support from a member of staff, didn't expect that.

avatar image Bojanm1972 Oct 16 '15 at 09:30 PM

Thank you for answer, it help me a lot. Also, thank you for the question.

Best Regards

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question