x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

RunUAT.bat ERROR: AutomationTool was unable to run successfully.

hi ,

i did package my game succesfully for android but if i can build mygame to ios for development , everytime "RunUAT.bat ERROR: AutomationTool was unable to run successfully." errors give to me. (win 8.1 and UE version 4.4.2link text please ,what is wrong ?

i attached log file,

Product Version: Not Selected
Tags:
myerrorlog.txt (358.3 kB)
more ▼

asked Sep 09 '14 at 09:04 PM in Packaging & Deployment

avatar image

serhatuzuner
1 1 3 2

avatar image [Epic] Gribbs ♦♦ STAFF Sep 10 '14 at 01:45 PM

Howdy serhatuzuner,

Thank you for reporting your issue. I just need a bit more information from you before I dive into this issue. Would you be able to share you DXdiag and your project log files on this post?

If you load up a brand new project and attempt to package for iOS, do you still see the same errors as your personal project? Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image serhatuzuner Sep 23 '14 at 08:05 PM

dear sean still waiting your helps :) i did upload my first little game fundino Google play store but still waiting for ios :)

serhat

avatar image serhatuzuner Sep 10 '14 at 02:23 PM

hi dear sean, attached myerrorlog.txt file is my game log file.and now, and,i did make a new Project from UE 4.4.2 topdown blueprint game.and i did attach this Project error log file.

sincerely, thanks.serhatlink text

avatar image [Epic] Gribbs ♦♦ STAFF Sep 23 '14 at 08:35 PM

Hey serhatuzuner,

Sorry about a lack of response. Would you be using a binary or source version of UE4? Have you attempted to package on 4.4.3 since it has been released?

Thanks!

avatar image serhatuzuner Sep 24 '14 at 08:50 PM

hi sean, i'm using binary version ,blueprint Project (a tappy chicken based game) ,and i dd try package 4.4.3 but didn't package. i attached outputlog file for you for my wrongs.link text.

thanks.

outputlog.txt (428.0 kB)
avatar image TSpartanT Sep 24 '14 at 09:17 PM

I'm using 4.4.3 and getting the exact same issue. Hopefully you guys can fix it.

avatar image [Epic] Gribbs ♦♦ STAFF Sep 25 '14 at 08:15 PM

Hey serhatuzuner and TSpartanT,

It looks as though you may not have permission to write to C:\Program Files\Unreal Engine\4.4\Engine\Intermediate\UAT\IOS\ue4commandline.txt

You may not have permission to write to that directory, or there may be a ue4commandline.txt which is read-only

avatar image serhatuzuner Sep 26 '14 at 07:28 AM

hi dear sean , allthings make engine for package,i didn't change "ue4commandline.txt" or other file :)

what must i do for this ?

thanks, serhat

avatar image TSpartanT Sep 26 '14 at 05:57 PM

Just put your project in your documents instead of your Program Files

That'll fix the error :)

avatar image serhatuzuner Sep 26 '14 at 07:31 PM

hi TspartanT, i made this but still same error :) because of,i attached ue4commandline.txt and uat.log in 4.4/intermediate files

link text

uat_log.txt (34.1 kB)
avatar image serhatuzuner Sep 29 '14 at 11:52 AM

Dear sean , can you see last files for my errors

avatar image [Epic] Gribbs ♦♦ STAFF Sep 29 '14 at 08:30 PM

Have you switch versions of UE4 to 4.3? Looking at the log files, it seems like 4.3 is missing multiple .dll files. Have you tried to build this project in 4.4.3?

Thanks!

avatar image serhatuzuner Oct 02 '14 at 07:29 AM

Dear sean this log files 4.4.3 build log files. Thanks

avatar image [Epic] Gribbs ♦♦ STAFF Oct 13 '14 at 04:02 PM

Hey serhatuzuner,

Would you be trying to launch the project from Windows Explorer or from the UE4 launcher?

This may be from the reason why it is showing in the log files that the project is running in 4.3 instead of 4.4.3. You would need to open a copy of the project in the 4.4.3 version of UE4.

Thanks!

avatar image serhatuzuner Oct 13 '14 at 07:25 PM

dear sean, everytime UE4 launcher.i did copy to 4.4.3 but same error.

after,i installed UE 4.5.0 and make a new fps Project and make all properties after i packaged for ios .but still same error. i attached log file 4.5.0

dear sean why didn't i package any Project?

thankslink text

logfile.txt (343.2 kB)
avatar image [Epic] Gribbs ♦♦ STAFF Oct 14 '14 at 05:49 PM

Would you happen to have this directory: c:\program files\unreal engine\4.5\engine\intermediate\uat\ios ?

If you do not, create that directory and see if that fixes the problem that you have been seeing.

avatar image serhatuzuner Oct 14 '14 at 08:01 PM

dear sean ,yes i have this directory ?

i update 4.5.0 after did package this Project but engine gave same error. sorry :(

avatar image [Epic] Gribbs ♦♦ STAFF Oct 16 '14 at 05:33 PM

Hey serhatuzuner,

Would you be able to uninstall and then re-install UE4 on your PC? This has been able to fix the error for other users packaging for mobile.

avatar image [Epic] Gribbs ♦♦ STAFF Oct 20 '14 at 08:17 PM

Hi serhatuzuner,

Just wanted to check in with you and see if you had any luck with uninstalling of the Engine. Please let me know when you get the chance so that I may look further into this issue if it is still occurring.

Thanks and have a great day!

avatar image serhatuzuner Oct 21 '14 at 06:04 AM

dear sean , i have 2 system. one of them win 7 computer one of them win 8.1 computer.and i did uninstall both engine after reinstall and i did try package.but engines gave same error. (sorry for bad english) after i did change apple all profiles and id's after i did try.but the engine everytime gave same error.

what must i do ? i don't know.

avatar image [Epic] Gribbs ♦♦ STAFF Oct 30 '14 at 03:12 PM

Hey serhatuzuner,

Would you be able to attach the logs from a current failed build so that I may be able to further investigate the issue? Also, have you tried to resolve the issue by using the 4.5.1 build of UE4?

Thanks!

avatar image Michsaporito Oct 21 '14 at 12:59 PM

The same for me and much others.. In 4.5.0 the same.. The error is this.. alt text

avatar image [Epic] Gribbs ♦♦ STAFF Oct 21 '14 at 03:19 PM

Hey Michsaporito,

Would you be able to attach your Dxdiag and your Project Log files? Can you also include the entire build failed log?

Thanks and have a great day!

avatar image Michsaporito Oct 21 '14 at 04:09 PM

Many thanks! link text

uat_log.txt (344.9 kB)
avatar image Michsaporito Oct 21 '14 at 06:24 PM

Hi Sean! thanks for your attention.. I have the same report with Lightroom and Realistic Rendering for 4.5.0 I tried with a new scene but nothing.. I've the problem only with 4.5.0.. :( link text

dxdiaginfomichs.txt (423.9 kB)
avatar image [Epic] Gribbs ♦♦ STAFF Oct 22 '14 at 03:58 PM

Howdy Michsaporito,

Would you happen to have a paid subscription or a student redemption for UE4?

In order to use the Launcher and properly access UE4, you must have created a paid subscription account on UnrealEngine.com. Once you have this, you can download the Launcher from your account page, which once installed will then download and install the UE4Editor.

We can only offer installation & setup support for users accessing the editor from the Launcher or from our GitHub repository.

Have a good day!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

Hi serhatuzuner,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

more ▼

answered Nov 04 '14 at 10:12 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

avatar image serhatuzuner Nov 11 '14 at 10:00 PM

hi dear sean, i did try package for UE 4.5.1 but i didn't package, everytime engine gave outamation tool error.

i did uninstall and reinstall Windows after repeatly install UE4 but i didn't package anything for ios :)

i send last sample Project log file for error

serhatlink text

logfile4.5.1.txt (272.4 kB)
avatar image Ravlek STAFF Nov 18 '14 at 06:41 PM

serhatuzuner,

We convert the UE4CommandLine.txt and its entire path to lower case before writing out the file. Can you verify if you have a c:\program files\epic games\4.5\engine\intermediate\uat\ios directory or a c:\Program Files\Epic Games\4.5\Engine\Intermediate\UAT\IOS directory?

-Pete

avatar image Ravlek STAFF Nov 18 '14 at 07:32 PM

Actually, I am pretty sure I know how to fix this particular issue. I'm pretty sure it's our call to lower case the path. We aren't specifying a culture in that case and I am sure it is just picking an unexpected character.

-Pete

avatar image serhatuzuner Nov 20 '14 at 12:05 PM

dear pete , i have these path and files in epic games file :)

but i can't understand lower case path event and specifying culture unexpected character event

sorry but,how can i change these on mycomputer

serhat

avatar image serhatuzuner Nov 28 '14 at 09:44 AM

hi dear sean and pete ,

"Actually, I am pretty sure I know how to fix this particular issue. I'm pretty sure it's our call to lower case the path. We aren't specifying a culture in that case and I am sure it is just picking an unexpected character.

-Pete " still waiting a help for how can i fix these events

serhat thanks

avatar image Ravlek STAFF Dec 01 '14 at 06:45 PM

Unfortunately, you can only fix this if you build the tools themselves, so if you utilize the GitHub release then you could build the tools with the fix which is just a matter of utilizing the ToLowerInvariant version of the string functions. Without that change, you would have to specify English as your default culture on your computer. This is fixed in 4.6 which is probably the easier path to take for resolving the problem.

-Pete

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question