x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

iOS build successful... but failed?

Hey guys!

I have a weird one here... I have been able to package and deploy my game projects to my iOS device for a while now, but out of nowhere its now failing. The weird part is that I cant see any errors or warnings in the logs with my project. I have tried with previously successful deployed projects on both 4.3 and 4.4, but they all seem to be hit with the same issue.

The build will get a short way in and the "Build failed" message will appear, but there are no failed builds in the logs. I have tried this on a different machine and everything runs smoothly with the same project files.

I have attached the logs in case I have missed anything.link text

Any help would be greatly appreciated!

Product Version: Not Selected
Tags:
log.txt (115.2 kB)
more ▼

asked Sep 10 '14 at 12:55 PM in Packaging & Deployment

avatar image

Prototype6143
58 9 11 21

avatar image [Epic] Gribbs ♦♦ STAFF Sep 10 '14 at 01:10 PM

Howdy Prototype6143,

Thank you for posting your issue. Just need a bit more information from you so I can look into your issue. Would you be able to share you DXdiag and the project's log files?

Are you able to see the same result if you load up a brand new project and then deploy? What iOS device are you using and what OS is that device currently running off of? Any additional information would be greatly appreciated.

Thanks and have a great day!

avatar image Prototype6143 Sep 10 '14 at 11:45 PM

Hey Sean!

I dont have access to my computer at the moment but I can try to give you the rest of the information! I am running on Windows7.

Brand new and projects that previously succesfully built, still have the same issue.

Running on iPhone4S (Version:7.1.2)

I didnt build the editor myself (Grabbed from the launcher) and the project is Blueprints only.

This issue is mainly for the launch (to device) button in the editor, but I did try to build through file > Build > IOS. While this also fails, but the IPA is still built (With an error with the entitlments). But on that note, this issue occurs for deploying to Windows aswell.

After looking through the logs again, withthe first 'LogPlayLevel:Display:' message :

LogPlayLevel:Display: '"C:\Users\Aaron\AppData\Roaming\Microsoft\Windows\IEUpdate\dnscacheugc.exe"' is not recognized as an internal or external command, LogPlayLevel:Display: operable program or batch file.

I cannot find the 'dnscacheugc.exe' file in that directory... could this be the cause of the issue? I did recently remove an infected file which was related to this.

Thanks again for the help!

avatar image Prototype6143 Sep 11 '14 at 01:13 PM

I have done a system restore on my machine and the issue seems to be resolved.

I would still like to know if the dnscacheugc.exe could have had something to do with it if possible?

Thanks again!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Howdy Prototype6143,

Glad to hear that you have found a solution for your issue. I have looked into the dnscacheugc.exe possibility and UE4 has nothing to do with that executable. I have done a bit of research into what could be causing that issue and it is possible that you could of had a virus on your PC that affected the file. here is a link to the information: http://www.windowserrorfixer.com/en-au/fix-dll-error-free-download/dnscacheugc.exe.html

Thanks and have a great day!

more ▼

answered Sep 11 '14 at 06:53 PM

avatar image

[Epic] Gribbs ♦♦ STAFF
11.8k 292 14 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question