x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Emissive Light on DM object?

Hello, i´ve got a material which emits an emissive light, on Brushes and StaticMesh it works fine, but when i try to put this Material onto a Destructible Mesh is just shows the blank sphere (as there were no material on it), the material tab shows the emitting material!

Is it even possible to have emitting DMeshes?

(Picture shows selected DMesh (emissive ball on the left is a static mesh))

alt text

Product Version: Not Selected
Tags:
emi question.jpg (440.7 kB)
more ▼

asked Sep 10 '14 at 02:10 PM in Rendering

avatar image

SteamGear
17 9 8 14

avatar image Jacky Sep 10 '14 at 02:15 PM

Can you post a screenshot of the problem please?

avatar image SteamGear Sep 10 '14 at 02:56 PM

here you go

avatar image Jacky Sep 10 '14 at 03:08 PM

Hmm, that's strange. I just tried it both with a Default and Unlit shading models with an emissive color plugged to emissive channel and i can see the material as normal, just like your static mesh. I don't know what can be wrong. :\

Which version are you using?

avatar image SteamGear Sep 10 '14 at 05:38 PM

Using 4.4.2 i used the First Person blueprint and starter content maybe there is an issue somewhere

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi SteamGear,

I've tried duplicating this in 4.4.2 with a destructible mesh, but did not get the same result you did.

Here is a screen grab of my destructible mesh with two emissive colors (outer and inner texture).

alt text

I know it's probably a simple texture, but can you post a screenshot of your material setup as well for the emissive texture?

Also, are you able to reproduce this in a new project or just this one?

Thank you!

Tim

dmemissive.png (174.6 kB)
more ▼

answered Sep 11 '14 at 05:37 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image SteamGear Sep 12 '14 at 11:58 AM

Managed to fix it, in my Material i set the Material Domain to Light Function, thats why the DM didnt show it, swapping back to "Surface" fixed this issue

avatar image Tim Hobson ♦♦ STAFF Sep 12 '14 at 12:56 PM

That'll do it! :)

I'm glad you figured it out and for posting your update!

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question