Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Upgraded to Engine Version 4.4.2, 64 Bit Tools are not installed

I upgraded my binary version of the engine to version 4.4.2, and now I cannot generate project files, add code to the project, or compile through visual studio. I cannot even create a template project! I always get the below error:

Please ensure that 64bit Tools are installed with DevStudio - there is usually an option to install these during install

I am going to try a re-install of Visual Studio 2013 and make sure 64-bit tools is checked, but is this a known issue?

NOTE: I have another system where I have an older 4.4.1 installation and this is working fine...

Product Version: Not Selected
more ▼

asked Sep 11 '14 at 10:50 AM in Bug Reports

avatar image

354 13 9 25

avatar image jaragoondoo Sep 11 '14 at 11:01 AM

A quick update, I have downloaded and compiled the source for Engine Version 4.4.1 on this system and I am NOT getting the above errors (so clearly something is broken in 4.4.2).

avatar image Steve Robb STAFF Sep 11 '14 at 03:56 PM


I believe an accidental dependency has been added to this hotfix where a test for a .NET Framework SDK is being made, but failing. This shouldn't be necessary if you're not using C# projects, but the test is being made regardless.

As a workaround, could you try adding the following environment variables to your system and rerunning UE4:


It shouldn't matter what these are, as long as they contain some value.

Or install a Windows SDK.

Hope this helps, sorry for the trouble. Please report back on whether this has solved your issue.


avatar image sivan Sep 13 '14 at 05:42 AM


the same here. even any VS compilation is impossible, including editor source of 4.4.2. where and how to set those variables exactly?

thanks. Ivan

Edit: with 4.4.3 preview source everything works fine again.

avatar image Steve Robb STAFF Sep 15 '14 at 09:24 AM

Glad the 4.4.3 update is working.

For anyone else: setting environment variables is a Windows thing, for example:



(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

EDIT: I haven't tested what Steve has posted below, but if it has worked for someone else then it may work for others so I'll mark this as answered for now :)

Hi Steve

I'm not on that system at the moment so I cannot check, but I don't have admin rights so I'm not sure if I can add environment variables. I'll check when I have access anyway (I'll try the Windows SDK, too, I just need a technician to install it for me!)

more ▼

answered Sep 11 '14 at 06:32 PM

avatar image

354 13 9 25

avatar image Steve Robb STAFF Sep 12 '14 at 04:19 PM

Hi again,

The workaround has been confirmed to work by this other user:



(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question