x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't disable gravity for skeletal mesh

This has stumbled me a bit. I started off with the Flying UFO template. It has disabled gravity and use C++ code to move the ship around. Works great, except it doesn't really handle physics and collisions.

I replaced the static mesh UFO with a skeletal mesh for bone animations of a bird flying, but it keeps falling to the ground. I've tried disabling gravity on the skeletal mesh, but it still falls as if gravity applies to it. If I disable physics altogether, it does not fall, but I want collision physics and Hit events. The mesh has a physics asset with a single body of about 2 kg. If I go back to the UFO static mesh with the same settings (physics on, gravity off), it does not fall to the ground. Is this something fundamentally different for skeletal meshes? Can't I disable gravity while still simulating physics?

Reproduced on 4.3.1 and 4.4.2.

Product Version: Not Selected
Tags:
more ▼

asked Sep 11 '14 at 06:59 PM in Everything Else

avatar image

angularsen
16 1 2 5

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Anjdreas,

That is a known bug with setting gravity. The current work around is to instead get a reference to the movement component, then drag off of that to do a "Set Gravity Scale" and make that 0. Let me know if that works for you.

Thanks,

Alexander

more ▼

answered Sep 11 '14 at 10:40 PM

avatar image angularsen Sep 12 '14 at 06:51 PM

Thank you, I thought I was losing my mind for a while there :-) Could not find any relevant info googling or searching this forums on this, hopefully this post will help others.

avatar image bgkdw Mar 07 '15 at 07:20 AM

I encounter exactly the same problem in version 4.6.1. Has this bug been fixed now?

avatar image Samantha Sutton ♦♦ STAFF Mar 11 '15 at 02:16 PM

Hey Bgkdw,

This issue is still being worked on by our developers, the report number is: UE-11622. This will be corrected in a future update of the Engine. If you have any further questions, please let us know!

Thanks!

avatar image TriNityGER Jul 19 '15 at 01:54 AM

Has this been fixed yet?

avatar image Samantha Sutton ♦♦ STAFF Jul 20 '15 at 07:28 PM

Hey,

This issue has not been fixed yet. It currently has an ETA to be corrected in 4.10 however this could change depending on the priority of the matter as new updates are submitted by our developers. Please feel free to check back in a few weeks.

Thanks!

avatar image Samantha Sutton ♦♦ STAFF Sep 10 '15 at 02:20 PM

Hey Everyone,

I have just received the Jira report back. This is actually a 'by design' issue. Gravity is controlled per body in a skeletal mesh, you need to set the flag on bodies in the PhAT editor if you'd like to make changes.

Thank you!

avatar image Burnrate Dec 01 '16 at 02:37 AM

Hi

Can you explain this further? This is for how to enable/disable gravity on a skeletal mesh in gameplay correct?

I still get no results using either enable gravity false or setting the gravity scale to zero in character movement.

Do I need to setup something in PhAT?

Thank you.

avatar image Samantha Sutton ♦♦ STAFF Dec 07 '16 at 07:10 PM

Gravity would be controlled per body in a skeletal mesh therefore, you will need to set the flags on the bodies in the PhAT editor to create gravitational changes.

 no gravity:
 go and disable gravity for all bodies

 yes gravity:
 go and enable gravity for all bodies who's BodySetup.DefaultInstance.bEnableGravity == true

Documentation: Physics Asset Tool (PhAT)

If you have any additional concerns, I would suggest creating your own AnswerHub post, or forum post as this one is from 2015.

Thanks!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2019 and bug still in the engine. Stop working on fortnite, its a trash game

more ▼

answered May 29 '19 at 12:48 AM

avatar image

JTXPbrah
86 5 7 10

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question