x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Texture problems (i am using Paper2d)

Hello everyone,I am facing this huge problem with textures and sprites/flipbook animations inside my paper2d project. I am not an expert with textures so please forgive me if this can be fixed with a setting that i am not aware of. I have noticed that unreal does not show semi-transparent sprites during runtime.It is either 1 or 0. this is the original png.alt text

This is the imported texture.alt text These are the sprites.As you can see the semi-transparencies show in the previewalt text And this is the final result when i double click on a sprite.What you see here is what is rendered during runtime with the flipbook animation.alt text Why is this happening?I tried playing around with the settings but nothing seems to change.The system calculates semi transparencies as either 0 or 1 and the end result is very bad for what i am trying to create.Is this a "bug" or is there a setting that will fix this? Thank you

Product Version: Not Selected
Tags:
jump_cloud0004.png (13.9 kB)
3.png (382.1 kB)
1.png (88.8 kB)
2.jpg (354.3 kB)
more ▼

asked Sep 12 '14 at 01:54 PM in Rendering

avatar image

Roccinio
571 51 56 77

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Roccinio,

In the Sprite Editor, change the Default Material to TranslucentUnlitSpriteMaterial. If you don't see that option in the drop-down, go to View Options and enable Show Plugin Content. By default, this is set to MaskedUnlitSpriteMaterial, which won't show alpha correctly.

Hope that helps!

more ▼

answered Sep 14 '14 at 09:49 AM

avatar image

Caracole
123 11 10 20

avatar image Roccinio Sep 14 '14 at 03:24 PM

First of all i would like to thank you from the bottom of my heart for helping me out! Not in a million years would i imagine that i had to enable show plugin content and choose TranslucentUnlitSpriteMaterial for it to work properly.But i am still facing a problem and i would like your opinion.This is the sprite after the changealt text this is the reference viewer for the flipbook.As you can see everything is as intended.alt text

1.png (355.5 kB)
3.png (265.1 kB)
avatar image Roccinio Sep 14 '14 at 03:27 PM

And this is from inside the flipbook editor. alt text Nothing changed!during runtime i still see the old sprites.How is this possible? Do you think this is a bug and i should report it or there is another setting that updates the flipbook? Thank you

2.png (261.6 kB)
avatar image Caracole Sep 14 '14 at 04:27 PM

Once you placed your flipbook in your game, you can edit the material and set it to TranslucentUnlitSpriteMaterial. The flipbook will still preview using the default sprite material but in game it should be displayed correctly ;)

avatar image Roccinio Sep 15 '14 at 06:16 AM

I will report it as a bug since it is not working as intended and thanks again for your help. Cheers!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question