x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

UE4 freezes my PC when building lighting

Hello I have Unreal Installed on 2 PC's in my house. I just built a new PC built specifically for making games in UE4. Whenever I start I hit the build button with in the editor it begins fine then freezes at 0% then locks up my PC and the screen starts to shake. The only way to fix this is to turn off the PC by holding the power button down. What can i do to fix this like I said brand new PC with all brand new parts.

PC Specs: AMD Phenom xII @3.4Ghz, Nvidia GTX 680 2GB, Gigabyte 970A-D3P Motherboard, 8GB DDR3 Ram, 2TB Western Digital Hard Drive, 750W Power Supply.

Product Version: Not Selected
Tags:
more ▼

asked Sep 13 '14 at 07:34 PM in Bug Reports

avatar image

Panda256
1 1 3 3

avatar image Jacky Sep 13 '14 at 07:48 PM

Screen shaking sounds strange. Is the same thing happening even if you build lights for a small level like the startup map with chairs and table? Is your CPU fan working properly(and check the temperature if you can when you start building the lights)? Are all of those parts brand new?

avatar image Panda256 Sep 13 '14 at 07:53 PM

yes everything is brand new and the cpu temp is at 32-42 degrees with all the current drivers

avatar image Jacky Sep 13 '14 at 08:20 PM

Hmm. How about the gfx...which driver do you currently have installed? And can you post your dxdiag report please? I dont think i'll be able to help you further but those may help Epic staff investigate the issue easier. I moved your post to Bug Report section, btw.

avatar image Panda256 Sep 13 '14 at 09:21 PM

the current graphic driver is 340.52. here is the dxdiag

dxdiag.txt (61.9 kB)
avatar image Panda256 Sep 14 '14 at 12:19 AM

I now got it to load to 100% but it gets stuck on starting up swarm connection and the system still freezes

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

Hi Panda,

I'm currently using a similar setup for my work machine but I do not get things like this going on.

You said you have two computers that have UE4 installed. Is your other one giving you any sort of issues?

Also, when you try to build lighting which project/template are you using? Are you using a unmodified template and getting this issue?

Thank you!

Tim

more ▼

answered Sep 16 '14 at 03:05 PM

avatar image

Tim Hobson ♦♦ STAFF
48.8k 887 101 878

avatar image Panda256 Sep 16 '14 at 03:11 PM

I don't have this problem on my other pc at all. I'm using the First person template

avatar image Panda256 Sep 18 '14 at 11:31 PM

any ideas?

avatar image Panda256 Sep 22 '14 at 10:22 AM

installed the new nvidia drivers that came out 2 days ago and still having the same issue.

avatar image Tim Hobson ♦♦ STAFF Sep 22 '14 at 09:08 PM

You seem to have a system that is up to spec. I'm not exactly sure why this is happening and it's not something I can reproduce on my end. Can you try uninstalling the engine and reinstalling to see if this helps?

avatar image Panda256 Sep 22 '14 at 09:14 PM

Yes i did try re-installing it 2 days ago and also tried the GetHub version. It still freezes and locks up my pc at 100% when trying to start connection to the swarm client. The new nvidia drivers removed the screen shake that i was getting but my system will still lock up and i have force my pc to restart by pressing the power button to be able to use it again.

avatar image Panda256 Sep 26 '14 at 10:43 AM

Is there another way to receive tech support, because I would really like this to be taken care of so I can get back to our project. We have already been set back 2 weeks now by this problem and really cant afford to be waiting anymore.

avatar image Tim Hobson ♦♦ STAFF Sep 26 '14 at 02:28 PM

The only other suggestions I have for you at the moment would be to try would be to delete the SwarmCache folder located in C: \ users \ [Computer name] \ AppData \ Local \ Unrealengine \ [Engine Version] \ Saved \ Swarm \

Delete the Swarm Cache folder.

If this doesn't work try increasing your Virtual memory in windows. 8gb's of RAM will go quickly and this may be the reason the computer is freezing. If that's the case I would suggest upgrading your amount of RAM.

Let me know how this goes.

Tim

avatar image Panda256 Sep 26 '14 at 09:51 PM

I tried to delete the Swarm Cache folder and tried installed another 8gb's of ram from my other system making it a total of 16gb but both did not work. The system still freezes.

avatar image Tim Hobson ♦♦ STAFF Sep 29 '14 at 07:50 PM

I know this is frustrating but here is something else we can try. I won't mislead you on this, but I'm running out of possible things to try aside from re-installing windows to see if that helps. I don't want to necessarily suggest that though.

Ok, try to disable any anti-virus & firewalls (including windows default). Try deleting the Swarm Agent cache data again then restarting the build process. And try running the editor as Administrator.

Thank you for your patience and willingness to work on this.

Tim

avatar image Panda256 Oct 01 '14 at 01:49 AM

I have tried but it still freezes my system. I also did some testing to see if it was the video card or CPU using 3D Mark and got a 11302. So I don't believe that it ether of them or any hardware everything is temping out correctly with correct voltages. So i'm guessing the next step is to do a full system re-install?

avatar image Tim Hobson ♦♦ STAFF Oct 02 '14 at 08:09 PM

It's a possibility this may resolve the issue, but I cannot guarantee it. This has resolved one case in the past that I'm aware of, but so has the other solutions I've recommended as well.

avatar image Panda256 Oct 06 '14 at 12:04 AM

So I just re installed windows 8.1 and it working now. From what I'm guessing the windows install had a problem with the swarm client and it seamed to get stuck in a loop, could be the cause of my PC freezing up. But everything is working fine now thanks for the help. Is there anyway to get some credit for the whole month of not being able to use the engine?

avatar image Tim Hobson ♦♦ STAFF Oct 06 '14 at 04:53 PM

I'm glad this ended up resolving the issue. We'll be in contact soon with you to discuss this further. Thanks for all your help and patience as well! :)

Tim

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

still having problems. Can someone help please?

more ▼

answered Sep 17 '14 at 09:12 PM

avatar image

Panda256
1 1 3 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question