x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal Installer Service Pack 1 - Cannot install

So I downloaded the UE setup, and prompted it to run. Once the installer initializes it says

"Microsoft Windows 7 Service Pack 1 is required when installing on Windows 7. Please install SP1 and run the installer again."

Then proceeds to close itself. Here's the kicker, I installed SP1 immediately after through windows update but it doesn't seem to have worked. I tried a manual install and still have no such luck.

Could anyone provide some insight as to what is happening and some thoughts on how to fix this issue?

Product Version: Not Selected
Tags:
more ▼

asked Sep 14 '14 at 08:53 PM in Installation & Setup

avatar image

Meat Juice
41 2 3 68

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

I Fixed the issue, the problem lay within the compatibility mode!

Windows itself solved the issue when I right clicked and chose the shell extension "Troubleshoot compatibility"

The installer booted happily with no issues!

more ▼

answered Sep 15 '14 at 04:51 AM

avatar image

Meat Juice
41 2 3 68

avatar image 0xDEADBEEF STAFF Sep 15 '14 at 04:53 PM

Glad you got it working in the end. I believe 1603 implies that one of the installer custom actions is failing and a closer look at the log would probably pinpoint the issue. It looks like the msilog link that you posted points back to this thread and not the actual log. If you still have that log sitting around, perhaps you can zip it up and post it so I can have a look. I would like to fixup the underlying issue so we can prevent others from encountering it.

avatar image l_-IP-_l Nov 10 '15 at 10:19 AM

This was same error I got and luckily troubleshooting compatibility fixed it!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Sorry to hear that you are running into issues installing. Did the SP1 install complete successfully and were you prompted for a restart after the SP1 install?

To help further we'll need more info about your Windows environment and possibly logs from the installer which should tell us exactly why it failing to properly recognize your SP1 install. This link outlines some steps for obtaining the log in the MSI (Windows only) installation issues section: LINK

more ▼

answered Sep 14 '14 at 11:38 PM

avatar image

0xDEADBEEF STAFF
1.5k 18 11 47

avatar image Meat Juice Sep 15 '14 at 04:47 AM

I'm running Windows 7 Ultimate (service pack 2 originally).

here's the msilog

I believe the code is 1603. I'll look into that for now. Let me know if the log helps at all!

avatar image Trojar Jan 23 '16 at 06:28 AM

I also got the same problem but I saw Meat Juice's answer and I got it fixed.Tnx for sharing Meatjuice.

avatar image Ozcorps Mar 28 '16 at 02:50 PM

Im on windows 10 and to see this error well i was amazed but thanks MeatJuice. worked liked charm what ever it did in there..

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question