x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Beam Emitter - Use Local Space not being checked

The "Use Local Space" option does not work for beam emitters; the checkbox remains unchecked. Intentional or not, this is a pretty important feature. I'd like to attach a beam emitter to a vehicle, but the beams lag pretty far behind as a result of them being simulated in world space.

Is there an alternative setting I'm missing?

Product Version: Not Selected
Tags:
more ▼

asked Sep 14 '14 at 11:42 PM in Bug Reports

avatar image

OhiraKyou
306 21 43 54

avatar image Lovecraft_K ♦♦ STAFF Sep 15 '14 at 03:12 PM

Hey OhiraKyou -

What are your Source and Target settings in the Beam Emitter set as? You should be able to set up a relative location check on a source object (your vehicle) and a random point (you can create a target point in the blueprint to use as a reference) in from of the vehicle. By doing this setup in your blueprint you should have complete control over your beam without absolute position/location lagging.

Thank You

Eric Ketchum

avatar image OhiraKyou Sep 15 '14 at 04:17 PM

The emitter is parented to the vehicle, with the start and target offset by 75 left and right (user set). The beam itself is what's lagging behind the vehicle, because it is being simulated in world space (the individual beams would never separate from each other during a turn if that weren't the case). I've tried using the other source/target methods, but that doesn't change the fact that the beam is being simulated in world space.

Before turn (stationary):

stationary

During turn:

turning

Settings:

alt text

beamstationary.jpg (85.8 kB)
beamturning.jpg (95.0 kB)
beamsettings.jpg (34.3 kB)
avatar image Lovecraft_K ♦♦ STAFF Sep 18 '14 at 08:08 PM

Hi OhiraKyou -

I've been trying to reproduce the behavior you have shown above and have not been successful yet. Would you be able to upload a sample project showing this issue?

I will continue my investigation, but let me know -

Thank You

Eric Ketchum

avatar image OhiraKyou Sep 18 '14 at 08:59 PM

Here is an example project. Simply look around with your mouse to see the beams separating as they lag behind the camera's rotation (using the TestGameMode in TestMap).

avatar image OhiraKyou Sep 24 '14 at 10:20 PM

Have you tried the example project in my last reply yet?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

3 answers: sort voted first

I've been analyzing the issue for going on a year now and finally found a solution in my project. What I finally discovered was that if you have a physics simulating body that contains a particle system anywhere in its hierarchy, that particle system will have a tendency to lag behind the physics simulation.

The ultimate solution for me was to change the tick group of the thing that my particles were attached to so that they are Post_Physics.

Alternately if you are calculating values and setting your emitter position by hand, make sure that the work happens in a tick function that occurs Post_Physics.

I posted a few more details in my lab notebook.

more ▼

answered Jan 26 '16 at 05:59 AM

avatar image

hyperdr1ve
593 28 51 118

avatar image vle07 Sep 16 '17 at 08:25 PM

Does this solution still work? Using 4.15, the beam still lags behind my actor even after I change the tick group of the actor (on which the beam is attached) to Post_Physics.

Edit: Actually, I was able to get rid of the lag by setting the particle system component's tick group to Post_Physics. Seems like the tick group isn't inherited from the actor.

avatar image phisigma Jul 12 '18 at 08:18 AM

That does not work for me.

See UE-61695 for the corresponding bug report. The announcement for UE 4.20 Preview says “Niagara is now available as Early Access.” So I don’t think that this issue will be fixed.

That’s why I am still interested in a workaround, but I am nearly sure that there is none.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey OhiraKyou -

My apologies for the delay getting back in touch with you. Good news though, I beleive that you can easily fix the issue you are having by unchecking the "Lock Target Tangent" and "Lock Source Tangent" in the Target and Source modules respectively.

Thank You

Eric Ketchum

more ▼

answered Sep 25 '14 at 06:59 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image OhiraKyou Sep 25 '14 at 10:08 PM

The emitter still lags behind as a whole now. I think I checked the lock settings in an attempt to fix the larger problem of the entire emitter not immediately moving with its parent. Here is an example in which I've added spheres where the beam's source and target should be and rotated the emitter to make it easier to see it moving. Even setting the source and target to follow these spheres doesn't help. While looking around quickly, you can easily see the emitter failing to keep up.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hey OhiraKyou -

Thank you for the second project it helped me see exactly what your issue is. I have entered a report (TTP#347838) and I will keep you informed as we work on a solution.

Thank You

Eric Ketchum

more ▼

answered Sep 26 '14 at 02:43 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.7k 702 260 735

avatar image hyperdr1ve Jan 23 '15 at 03:00 AM

Eric can you tell me what the status of TTP#347838 is? I'm facing this same issue: https://answers.unrealengine.com/questions/162745/post-physics-update-attached-object-jitter.html Is it slated to be fixed in 4.7?

avatar image Lovecraft_K ♦♦ STAFF Jan 23 '15 at 07:52 PM

Hey hyperdr1ve -

We are still working on this particular issue and it does not look like it will be fixed for 4.7. I have updated the bug report with you information and for our reference in tracking this issue internally, UE-3358

avatar image jaragoondoo Mar 31 '15 at 06:27 PM

Any update on this? I'm having the same issue where I have an "lightning ball" that lags behind the projectile because the particles are in world space when I want them to be in local space with the projectile (the "lightning ball" particle system is a component/child inside of my projectile blueprint).

avatar image Lovecraft_K ♦♦ STAFF Mar 31 '15 at 07:36 PM

Hi -

Unfortunately this issue is still backlogged currently. I currently do not have an ETA for the fix.

Eric Ketchum

avatar image eviltenchi May 14 '15 at 10:23 PM

Has this been fixed in 4.8?

avatar image Lovecraft_K ♦♦ STAFF May 15 '15 at 03:57 PM

Hi eviltenchi -

This issue is still backlogged, I still do not have a definitive ETA on the fix.

Eric Ketchum

avatar image mairsil Dec 04 '15 at 06:48 AM

Any updates yet? This pretty much makes beam emitters useless for movable pawns.

avatar image Lovecraft_K ♦♦ STAFF Dec 04 '15 at 02:31 PM

Hello -

Unfortunately our engineers have deemed that this issue will not be fixed in the foreseeable future, in part because of the development of Niagara as a replacement for Cascade.

Thank You

Eric Ketchum

avatar image mairsil Dec 04 '15 at 10:54 PM

Any ETA on Niagara? It seems like that has been pushing off Cascade bug fixes for over a year now.

avatar image eagletree Apr 05 '18 at 10:09 PM

Has any progress been made on this issue. We are experiencing it in 4.18.

avatar image phisigma Jul 10 '18 at 05:34 PM

Unchecking LockSource and LockTarget in the source and the target module is a workaround, but unfortunately it is not an opportunity for me :-(

Epic, please show a minimum of grace and solve this issue. There is no Niagara.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question