x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Why are my scene's lighting and post process settings different depending on the computer?

I built a beautiful ArchViz scene at home that features bright and soft sunlight. To bring it to the office and share it with my coworkers (who are new to UE4), I zipped up the whole project directory and uploaded it to Google Drive. At work, I downloaded and extracted the files and fired up a fresh install of Unreal Engine.

The scene is very dark, the auto exposure and eye adaptation are not working at all, the lightmap resolution has been reduced by at least an order of magnitude (there are shadow bleeds and new splotches), and screen space reflections are totally absent. I've tried opening it in both the regular 4.4 engine as well as the source code version. I've re-downloaded and re-extracted the files to multiple locations. I packaged the game to HTML5 and it maintained all the same problems, although I expected errors regardless due to limitations. Tweaking the eye adaptation settings in the post-process volume does nothing for my lighting.

The worst part is: drum roll It works completely fine on my coworker's computer. Everything is perfect, even though it is the same downloaded file.

The .exe of the same scene that I built from home runs just fine on my computer, so it can't be a hardware issue, right? I'm so confused. Please help!

Product Version: Not Selected
Tags:
more ▼

asked Sep 16 '14 at 11:04 PM in Rendering

avatar image

StephaBon
16 3 11 16

avatar image Lovecraft_K ♦♦ STAFF Sep 17 '14 at 07:07 PM

Hey StephaBon -

Could you post some screenshots of the different renderings, one with the correct look and one with the incorrect look? Also I think that this is an issue where I might need to see your project to help diagnosis the issue. Can you share it with us? If you want to keep it private feel free to message me on the Forums.

Thank You -

Eric Ketchum

avatar image StephaBon Sep 17 '14 at 07:25 PM

Thanks for the reply, Eric. 1) After some more exploration, I should clarify some things. I discovered that my lightmaps were not actually reduced in quality. Eye Adaptation is the biggest thing missing, and that helped to wash out any splotchiness in my existing lighting. So all I'm missing is Eye Adaptation and Screen Space Reflections.

2) It turns out that these lighting features are missing from ALL my Unreal projects, including the Architecture and Couch Knights scenes that function similarly to mine. For this reason, it's probably not worth it to send you my specific scene, since it is not the anomaly.

Again, I have a Windows build of this game that works fine, it's just all my editing projects that have this disabled. Like I mentioned, I installed UE4 on this comp just a day before discovering this problem, and I haven't touched any .ini files. Where should I look for a problem? Thanks.

![alt text][1] alt text

lighting_bad.jpg (61.7 kB)
lighting_good.jpg (177.2 kB)
lighting_good.jpg (177.2 kB)
(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hey StephaBon -

Can you go under Quick Settings >> Engine Scalability Settings >> Make sure that everything is set to EPIC? If it is go under Show >> Post Processing and ensure that your settings are checked true.

Thank You

Eric Ketchum

more ▼

answered Sep 17 '14 at 07:53 PM

avatar image

Lovecraft_K ♦♦ STAFF
36.8k 701 255 733

avatar image StephaBon Sep 17 '14 at 07:56 PM

oops, you posted right as I was answering. You are correct! It had automatically set scalability to Medium. Thanks for your help!

(comments are locked)
10|2000 characters needed characters left

Solved it! Because no one answered for a day, I had posted in the Forums, where Tim Hobson realized what was wrong. (https://forums.unrealengine.com/showthread.php?41628-Eye-Adaptation-and-Screen-Space-Reflections-not-working-on-my-computer)

My work computer has a slightly older graphics card, and I didn't realize that Unreal Engine modified it's graphical settings based on how much your computer could theoretically handle. Under the quick settings, I had to change the Engine Scalability settings back to high. It was only previewing what would be available on weaker platforms.

more ▼

answered Sep 17 '14 at 07:54 PM

avatar image

StephaBon
16 3 11 16

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question