x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Unreal crashes on save

I have a reoccurring issue with Unreal where my current project crashes every time I save. Almost every time at least. I had the issue before and it was solved after verifying and downloading again. This time that isn't solving it. I've sometimes gone in and re-imported several textures and then had it save OK (strange). I keep making changes to the material nodes and then whenever it either auto saves or I "Ctrl + S" it crashes. It usually is stuck on "determining asset backup validity". I went in and deleted the backup and auto save files, but no help. Obviously this is a problem I need to fix. Any help? Thanks

Note: this is a project specific issue, there must be something causing it.

Product Version: Not Selected
Tags:
more ▼

asked Oct 18 '14 at 04:57 AM in Bug Reports

avatar image

ScottMichaelH
1 1 2 2

avatar image ScottMichaelH Oct 19 '14 at 05:47 AM

It appears that the issue is specifically with the map file. I'm able to copy the assets from the project onto a new project via Windows 7 OK, but not the map itself. I can't change its name in Windows to fix it, save as a new name in Unreal, etc.It's looking like I may try simply replacing everything for a few hours in a new project if I can't figure out a better option ...

avatar image eXi Oct 19 '14 at 07:48 AM

It would be easier to help you if you could give us a crash log or tell us what was the last thing you changed before the crashs appeared.

avatar image ScottMichaelH Oct 19 '14 at 04:03 PM

link text

alt text

I'm not sure what I did beforehand other than build the lighting. Thanks.

crash.txt (2.2 kB)
crash.jpg (259.1 kB)
avatar image Jonathan Dorman STAFF Oct 21 '14 at 07:53 PM

Hey ScottMichaelH,

It sounds like you've got a corrupt asset. I would recommend finding the problem by creating a copy of the project and then deleting parts of the copy until you're able to run it. Whatever you deleted last is the problematic portion and can be narrowed down from there.

I believe when eXi asked for your crash report, he meant the one described here. That would help us find the cause of the problem.

avatar image ScottMichaelH Oct 21 '14 at 11:01 PM

Thanks for responding. I tried that. Every model, texture, material and light is fine. The only conclusion I came up with was the map file itself was bad. I ended up finding out how you can copy and paste the contents in the level from one map onto another in the same project, so this workaround ended up cheating the problem, though I never figured of the exact issue. The drawback then is I have to hope it doesn't come back on the new map file at some point.

As far as what I was doing, I have no idea! It wasn't as though I did something and then it crashed other than saving. Every time I saved it stopped on "determining asset backup validity" and crashed. I just happened on autosave at one point. I could've been doing anything (importing, re-importing, assigning, dragging, dropping, creating, changing values, linking nodes, etc.). Version is 4.4.3-2296771. My only guess is that it was autosaving a lot over a long time working on the map that maybe it just didn't want to do it anymore.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

2 answers: sort voted first

It's good to hear that you have a workaround, but let me know if the crash reappears. At least one other user has had a similar problem, although he's not responding and may have found a workaround of his own.

I'll mark this issue as Resolved for now, but let me know if the problem reappears.

Regards,

Jonathan

more ▼

answered Oct 22 '14 at 01:24 PM

avatar image Detilium Jun 15 '15 at 09:31 AM

I was having the exact same problem. Everytime I save the project, the UE4 crashes. This problem occurred as I was playing around with the TopDownCharacter blueprint, and making changes in the world settings.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I too have this problem and I must inform you that I do not drive named "D:" .. how can I change these paths. Please?

MachineId:707C061D4AAB43988C2CDA885CD9887B

EpicAccountId:

Unknown exception - code 00000001 (first/second chance not available)

Assertion failed: NewPosition >= 0 [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.6\Engine\Source\Runtime\Core\Private\Windows\WindowsPlatformFile.cpp] [Line: 59]

KERNELBASE + 35740 bytes

UE4Editor_Core + 3092349 bytes

UE4Editor_Core + 1597688 bytes

UE4Editor_Core + 1479058 bytes

UE4Editor_Core + 2981860 bytes

UE4Editor_Core + 773780 bytes

UE4Editor_Core + 2229609 bytes

UE4Editor_CoreUObject + 690620 bytes

UE4Editor_CoreUObject + 1541319 bytes

UE4Editor_UnrealEd + 1780841 bytes

UE4Editor_UnrealEd + 2625915 bytes

UE4Editor_UnrealEd + 2613112 bytes

UE4Editor_UnrealEd + 6316416 bytes

UE4Editor_UnrealEd + 3247874 bytes

UE4Editor_UnrealEd + 3243162 bytes

UE4Editor_UnrealEd + 3240820 bytes

UE4Editor_LevelEditor + 570935 bytes

UE4Editor_Slate + 588774 bytes

UE4Editor_Slate + 1534016 bytes

UE4Editor_Slate + 1552472 bytes

UE4Editor_Slate + 1029959 bytes UE4Editor_Slate + 1036953 bytes

UE4Editor_Slate + 1434649 bytes

UE4Editor_Slate + 2116506 bytes

UE4Editor_Slate + 2296435 bytes

UE4Editor_Slate + 432060 bytes

UE4Editor_Slate + 160583 bytes

UE4Editor_Slate + 832224 bytes

UE4Editor_Slate + 770598 bytes

UE4Editor_Core + 2484713 bytes

UE4Editor_Core + 2400763 bytes

UE4Editor_Core + 2489275 bytes

UE4Editor_Core + 2387186 bytes

user32 + 9485 bytes

user32 + 9063 bytes

UE4Editor_Core + 2490486 bytes

UE4Editor!FEngineLoop::Tick() + 3434 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launchengineloop.cpp:2193]

UE4Editor!GuardedMain() + 479 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\launch.cpp:131]

UE4Editor!GuardedMainWrapper() + 26 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:126]

UE4Editor!WinMain() + 249 bytes [d:\buildfarm\buildmachine_++depot+ue4-releases+4.6\engine\source\runtime\launch\private\windows\launchwindows.cpp:202]

UE4Editor!__tmainCRTStartup() + 329 bytes [f:\dd\vctools\crt\crtw32\dllstuff\crtexe.c:618]

more ▼

answered Jan 19 '15 at 01:42 PM

avatar image

Nfell12
1

avatar image Jonathan Dorman STAFF Jan 19 '15 at 04:13 PM

Hey Nfell12,

You don't need to change any paths - the problem is likely with your project. Could you make a new thread for your crash? That will make it easier for us to track your issue.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question