x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Variables reset after packaging [DEMO PROJECT INCLUDED]

Name of player character resets (to default value specified in parent class) after packaging. Very simple demo project HERE

  1. Play in Editor or Standalone Game = "Bob", correct name.

  2. Package the project (tested with shipping 32 bit build), launch packaged game and now the text says "(Unnamed)", which is default value specified in "Unit" class.

alt text

3: The bug is gone when you delete "skill" variable from "Unit" class or delete GetPlayerCharacter->get name->print name logic from "Skill" class.

Please fix it :)

Product Version: UE 4.8
Tags:
bobissad.jpg (104.9 kB)
more ▼

asked Jun 19 '15 at 11:43 PM in Bug Reports

avatar image

Slavq
2k 157 153 210

avatar image CodeSpartan Jun 25 '15 at 05:49 AM
  • would also like this to be solved.

avatar image TJ V ♦♦ STAFF Jun 25 '15 at 01:01 PM

Hi CodeSpartan,

Thank you for showing your interest in this. I updated the JIRA to show that multiple users are looking for this issue to be fixed.

Cheers,

TJ

avatar image Slavq Jun 25 '15 at 05:39 PM

Update/Additional info: This bug resets many different variables from different classes, not only names. For example it resets one Texture2D type variable but also a few boolean variables of one of my blueprints, which is game breaking after packaging.

I really need this to be fixed 'asap', i hope that my little test project will be useful for fixing this bug. Thanks

avatar image Ben Halliday STAFF Jun 26 '15 at 06:43 PM

Thanks Slavq,

I've added these notes to the bug report TJ created. We'll post here when we see an update on the bug. Thanks!

avatar image Slavq Jun 29 '15 at 12:14 PM

Thanks, i have an another update: This bug is very similar to THIS ONE, both resetting variables after packaging when blueprints are referencing each other in certain way. Probably it's the same bug, or it has the same cause/origin.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hi Slavq,

Thank you for the test project. I was able to reproduce the issue and have created JIRA UE-17464 in our tracking software. We will post back here with updates as we have them.

Cheers,

TJ

more ▼

answered Jun 22 '15 at 06:06 PM

avatar image

TJ V ♦♦ STAFF
41k 1009 183 494

avatar image John Alcatraz Jul 23 '15 at 05:38 PM

Any update? Is it fixed in 4.9?

avatar image TJ V ♦♦ STAFF Jul 23 '15 at 06:44 PM

Hi John,

This is fixed. It is currently slated for 4.9 release. If you need it sooner you can get it here on GitHub.

Cheers,

TJ

avatar image John Alcatraz Jul 29 '15 at 06:28 PM

Hi TJ, I just tested it in 4.9P1 and it is not fixed.

avatar image TJ V ♦♦ STAFF Jul 29 '15 at 08:32 PM

You are right, it isn't working in 4.9 P1 but that isn't the final version of 4.9. Each preview will implement more and more features and bug fixes. If all goes well this fix should make it in.

Please keep in mind though, this fix is slated for 4.9 but it isn't guaranteed.. The devs prioritize bug fixes based off of the severity of the bug and the overall stability of the engine.

avatar image intoxicat3 Oct 13 '15 at 07:41 PM

Is this fixed in 4.9?

avatar image Slavq Oct 13 '15 at 07:50 PM

Yes, at least in my case :) Variables do not longer reset after packaging.

avatar image Mewbits Jan 13 '17 at 07:26 PM

Child Variables still reset to parent defaults at random in 4.14 (not when repackaging)

avatar image TJ V ♦♦ STAFF Jan 18 '17 at 09:30 PM

Hi Mewbits,

The original bug that was reported here was fixed and I just confirmed that it is still fixed in 4.14.3. What you are seeing is likely something new/different than what was reported here. Could you create a new post in the Bug Report section and include as much info as possible (exact repro steps, test project, screenshots of setup, etc)?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question