x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Crashes on Stereo everywhere

As of some point this morning, whenever I try to enable stereo, be it from VR Preview or by typing 'stereo on', and whether its in editor, standalone or pacakged, I now get an immediate crash.

I'm running a DK2 on Oculus 0.6.0.1, NVidia drivers 350.12. It was working earlier today and then my graphics drivers updated and it started crashing. I rolled it back to this version but the crashing is still happening. I have reinstalled the Oculus Runtime, the Graphics drivers multiple times and even the Unreal editor but nothing has worked.

Anyone got any ideas?

The error report is this:

 MachineId:294370BB4D32399A1FDE6EB431A3671D
 EpicAccountId:c08dc5fe722c4ceaaa00a8765c2f535b
 
 Unknown exception - code 00000001 (first/second chance not available)
 
 "Assertion failed: ViewFamily.RenderTarget->GetRenderTargetTexture() [File:D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Plugins\Runtime\Oculu
 
 UE4Editor_Core!FDebug::AssertFailed() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\misc\outputdevice.cpp:355]
 UE4Editor_OculusRift!OculusRift::FViewExtension::PreRenderViewFamily_RenderThread()
 UE4Editor_Renderer!RenderViewFamily_RenderThread() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\renderer\private\scenerendering.cpp:1328]
 UE4Editor_Renderer!TGraphTask<`FRendererModule::BeginRenderingViewFamily'::`17'::EURCMacro_FDrawSceneCommand>::ExecuteTask() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\public\async\taskgraphinterfaces.h:753]
 UE4Editor_Core!FTaskThread::ProcessTasks() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\async\taskgraph.cpp:430]
 UE4Editor_Core!FTaskThread::ProcessTasksUntilQuit() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\async\taskgraph.cpp:273]
 UE4Editor_RenderCore!RenderingThreadMain() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\rendercore\private\renderingthread.cpp:284]
 UE4Editor_RenderCore!FRenderingThread::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\rendercore\private\renderingthread.cpp:385]
 UE4Editor_Core!FRunnableThreadWin::Run() [d:\buildfarm\buildmachine_++depot+ue4-releases+4.8\engine\source\runtime\core\private\windows\windowsrunnablethread.cpp:73]


Product Version: UE 4.8
Tags:
more ▼

asked Jul 21 '15 at 01:13 PM in Bug Reports

avatar image

joewbrown
1 1 3

avatar image TJ V ♦♦ STAFF Jul 21 '15 at 02:52 PM

Hi joewbrown,

Thank you for the report. We have assigned one of our technicians to investigate your issue and they may post here with additional questions or comments.

Could you also include your Log, Dmp files, and Dxdiag (System Specs)? You can find where to get the info here.

avatar image Rudy Q ♦♦ STAFF Jul 21 '15 at 03:54 PM

Hello joewbrown,

I was unable to reproduce this issue on our end. I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Could you provide your dxdiag?

avatar image joewbrown Jul 23 '15 at 02:54 PM

Yes this occurs in a clean project. Here are the specifics:

  • Open Editor (4.8.2)

  • New Project with default settings (Blueprint, Blank, Desktop/Console, Maximum Quality, with Starter Content

  • Play in VR Preview

  • Crash

It crashes the engine and editor immediately. Playing in the default (non-stereo) mode plays fine, no crashing.

I've attached the logs, dmp and dxiag.

diagnostics.txt (45.5 kB)
myproject.log (118.8 kB)
ue4minidump.dmp.txt (367.4 kB)
dxdiag.txt (93.1 kB)
avatar image joewbrown Jul 23 '15 at 02:38 PM

I have attached my log, dmp and dxdiag files. I renamed my dmp file to "...dmp.txt" since it gave me an Invalid File Type error when trying to upload it as .dmp.

dxdiag.txt (93.1 kB)
diagnostics.txt (36.2 kB)
ue4minidump.dmp.txt (306.4 kB)
avatar image Rudy Q ♦♦ STAFF Jul 23 '15 at 03:00 PM

Hello joewbrown,

Thank you for the information that you provided. However, I will need you to answer the other two questions as well. I also have a couple of more questions after looking over your dxdiag.

More quick questions:

  1. When you say "As of some point this morning,...", is it safe to assume that you have had the oculus work correctly in UE4 on this machine?

  2. If you run the oculus in extended mode, do you still receive a crash?

avatar image joewbrown Jul 23 '15 at 03:20 PM
  1. Yes that's correct, it has previously worked on this machine.

  2. It crashes whether in Extended or Direct mode.

I was about to say that it still runs fine with the Oculus Demo scene and a Unity project but with those I'm now experiencing problems. For both, in Direct Mode it causes the headset to disconnect and reconnect, and in Extended mode they launch but I only get black screens.

This makes me think it's not Unreal's problem, but I am at a loss for what else since I have done clean reinstalls on both graphics drivers and Oculus runtime, with no change in results.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Hello joewbrown,

Due to the nature of your issue I would suggest contacting the oculus rift support team. I have provided a link below that you will be able to follow to put in a report. If this issue turns out to be an issue specific to the engine I will be more than happy to assist you further. Until then I am going to mark this question as resolved for tracking purposes. Please feel free to reopen the issue with additional information after contacting Oculus support.

Oculus Rift Support:

https://support.oculus.com/hc/en-us/requests/new

Make it a great day

more ▼

answered Jul 23 '15 at 05:43 PM

avatar image

Rudy Q ♦♦ STAFF
47.5k 545 132 522

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question