x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

LOD meshes import with 90 degree rotation

From Maya to 4.8.2

There are multiple topics created about this issue but I can't seem to find any solutions other than rotating the mesh in the 3D application before exporting.

This is obviously a workaround, but it needs to be fixed on the UE4 side.

The bug seems to be a result of importing LOD1+ meshes separately after you've imported your LOD0 mesh with 'Import Mesh LODs' unchecked. It also sometimes happens after reimporting an LOD mesh of a static mesh, if you've quit and re-opened UE4 since you last imported the mesh.

To work around it within the editor, static meshes have to be imported and allowed to overwrite the previous static mesh (as opposed to right-clicking the mesh in the content browser and selecting Reimport) and then LOD meshes can be correctly imported from the static mesh window. This is frustrating because then LOD Screen Size, lightmap settings, and collision settings need to be configured again for that mesh.

Any advice on how to prevent this or info on a possible fix being worked on would be appreciated!

Product Version: UE 4.8
Tags:
more ▼

asked Aug 03 '15 at 02:50 PM in Using UE4

avatar image

mechanicalsnowman
21 3 6 8

avatar image Lovecraft_K ♦♦ STAFF Aug 03 '15 at 03:54 PM

Hi mechanicalsnowman -

So I can accurately replicate the experience you are having, are you modeling in Maya with Y-Axis Up (Default) or Z-Axis Up (UE4 Default) and when you export from Maya as an FBX are you setting the Up Axis correctly to be Z-Axis Up?

Thank You

Eric Ketchum

avatar image mechanicalsnowman Aug 03 '15 at 04:25 PM

Hey Eric,

My Maya is Y-up, and my .fbx export is Y-up.

I haven't been using axis conversion for my exports because UE4 seems to handle Y-up .fbx exports perfectly from Maya (except for this LOD issue obviously!) and I assumed UE4 was making the decision to apply axis conversion itself if it knew the .fbx was from a Y-up application. (You can perhaps clarify if my assumption is true or if somehow it is magically working for me even thought it shouldn't be?!)

The user Anadin here also seemed to have the issue from Blender, which I believe is Z-up by default.

I'd rather not change my axis settings in Maya or in the .fbx exporter because I've been so far enjoying the neat way UE4 seems to handle Y-up meshes from Maya. And it would mean loading the .fbx meshes into Maya to make changes would be a nuisance if they came in at the wrong orientation.

I can use axis conversion on my LOD1 exports from now on as a temporary solution, but because UE4 handles normal mesh imports and LOD mesh imports inconsistently, even with the exact same settings during export from the 3D application, I feel it's something that should be corrected in the engine?

avatar image Logan Bailey ♦♦ STAFF Aug 03 '15 at 07:27 PM

Hello machanicalsnowman,

In maya there is no reason to work with Z-up, as there is a conversion on import.

All skeletal meshes and animations coming from Maya will be rotated 90 degrees off, (facing y-forward after import) Even Epic's examples have this offset. All you have to do is rotate the skeletal mesh, in the Blueprint, to face x Forward.

This will work with your situation as you do not want to re orient your meshes inside of Maya.

In the future, however, the workflow would be to orient your meshes to avoid this.

Thanks,

Logan

avatar image mechanicalsnowman Aug 03 '15 at 07:41 PM

Hi Logan,

Thanks for your reply, but I'm sure this doesn't apply to me. Please correct me if I'm wrong but -

the LOD issue I'm having is affecting static meshes, not skeletal, and as far as I'm aware you can't rotate or translate LOD meshes by using the static mesh editor (by which I mean the window where you can generate collision, generate lightmap UVs and view various information about the mesh - I'm not sure if it has a more appropriate / official name than the static mesh editor).

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Hey Mechanicalsnowman -

I was able to reproduce this step with some clarification from your link in reference to another users issue with this.

This bug has been reported to our development team at the time of the other users post.

I have added this post to that bug to reflect that more users are experiencing the same issue.

The bug number is UE - 5041

I apologize for the earlier confusion. In the meantime I would stick with your work around as it is working.

Thanks,

Logan

more ▼

answered Aug 04 '15 at 08:06 PM

avatar image mechanicalsnowman Aug 04 '15 at 09:04 PM

I see, thanks and sorry for the confusion. I'll continue to orient meshes before exporting in the meantime.

avatar image Kalle-H Jan 09 '16 at 06:50 PM

Any updates about this bug?

avatar image Logan Bailey ♦♦ STAFF Jan 10 '16 at 05:13 PM

This issue is still marked as unresolved.

-Logan

avatar image Kalle-H Jan 11 '16 at 10:00 AM

Just tested with 4.11 preview. It seems that 90degree bug is fixed but all LOD's now have wrong pivot after initial import.

avatar image Lovecraft_K ♦♦ STAFF Feb 24 '16 at 04:05 PM

Hi JennyGore -

If you have not already please post a new bug report about this issue. Give as much detail and instructions for reproduction as you can.

Thank You

Eric Ketchum

avatar image MikaelW Feb 24 '16 at 10:57 AM

Im having this problem as well. If I import the basemesh as a lod it will be rotatted 90 degrees...... :-S this is 24 feb 2016.

avatar image Lovecraft_K ♦♦ STAFF Feb 24 '16 at 04:08 PM

Hello MiikaelW -

This issue should have been corrected by CL-2711734, so by 4.10.0. Can you let me know what version of the editor you are using? If you are using source you can get the fix directly from the following Github commit:

https://github.com/EpicGames/UnrealEngine/commit/a4b2cc9a5d123e87b95d95d2f80ce02728c2c149

Thank You

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left

No,

There are ways of changing the pivot point inside of the viewport, however, once you select a different object then it does not persist.

This is a workflow issue, in the orientation needs to be established before importing.

Static meshes, by default, are not intended for movement so the change of orientation or axis is left to the developer.

At this time, this is not a bug and I will be moving it out of the bug reports.

However, if you would like me to do a feature request for this I will do that.

Thanks,

Logan

more ▼

answered Aug 04 '15 at 02:57 PM

avatar image mechanicalsnowman Aug 04 '15 at 03:18 PM

Thanks for the reply,

In one of the examples I gave of this issue happening, I can import my LOD0 and LOD1 mesh, and the orientation is handled correctly by UE4. Upon restart of UE4, reimporting the LOD1 mesh can sometimes result in the mesh coming in at the wrong orientation, even if it has been re-exported from the 3D application with the exact same settings. (Or I suspect, if it hasn't been re-exported at all and it is bit-for-bit the exact same file being imported)

Why is it necessary to re-orient LOD meshes while it is not necessary to re-orient LOD0 meshes? It's the inconsistency that makes me believe this is indeed a bug, along with the fact that the engine can produce differing results after being closed and re-opened since the static mesh was re-imported.

If I am truly mistaken and this behavior is intentional, I'd like to feature request that the editor handles automatic orient conversion on LOD meshes in the exact same way that it handles it on LOD0 meshes to remove this inconsistency, please!

avatar image Logan Bailey ♦♦ STAFF Aug 04 '15 at 03:44 PM

Hey Mechanicalsnowman,

First, The orientation inside of UE4 for up is Z not Y.

Secondly, we would love to reproduce this issue, however, without your assets and eliminating the possibility of it being an actual bug then we can't do this with assets on our end. This will be the only way to eliminate any outside factors and create a controlled test using the exact same variables as you.

In order to fully explore the possibilities of this being a bug on our end I would like to ask the following of you.

  1. Send me a .fbx and the Maya file of one of the assets that you have created so that I may check the exporting and orientation of your mesh, pre UE4.

  2. Re orient one of your meshes to Face Z and see if this fixes the issue.

  3. Let me know the results of 2 before you send me 1.

Thanks,

Logan

avatar image mechanicalsnowman Aug 04 '15 at 07:10 PM

Hey Logan,

I'm confused, since the first reply was from Eric Ketchum, saying:

So I can accurately replicate the experience you are having

So it seems like you can, and have reproduced the issue?

Exporting from Maya with an axis conversion set to Z does resolve the issue of LOD1 meshes coming in at a 90 degree angle, but this isn't necessary for any other mesh imports, so why is it necessary for LOD1 mesh imports?

avatar image Lovecraft_K ♦♦ STAFF Aug 04 '15 at 07:49 PM

Hi Mechanicalsnowman -

I apologize for the confusion, I meant Please let me know what you were doing in Maya and in the FBX so that I could accurately reproduce the issue not that I already had reproduced the issue, but I can see where that would be confusing now.

Eric Ketchum

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question