x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Cannot interact with 3D UMG Button

I'm following this tutorial, but I can't interact with the buttons like shown in the video, also I can't see my mouse cursor while running the game.

The title seems a duplicate, but I've read these questions (one) (two), and followed the suggestion of setting Pivot to (0, 0) still with no luck.

If I set the Pivot to (0.5, 0.5), which is the default value, I can somehow (randomly) interact with the buttons, but I can't see the cursor, all that I can do is blindly move my mouse around and suddenly the button becomes hovered.

Besides, my buttons are vertical, but my mouse has to move horizontally to hover through the buttons.

I'm using Unreal 4.9. Thanks!

Product Version: UE 4.9
Tags:
more ▼

asked Sep 07 '15 at 12:58 PM in Using UE4

avatar image

marsonmao
220 8 16 24

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Thank you for pointing out these issues. We are actually in the process of updating the tutorial you cited, but ran into the same issues as you. Our development team is aware of the issues and a fix for this is planned for 4.10.

Thanks.

-W

more ▼

answered Oct 14 '15 at 06:39 PM

avatar image

Wes Bunn ♦♦ STAFF
5k 145 64 206

avatar image zeOrb Oct 19 '15 at 12:28 PM

I'm in 4.10p1 and this still does not work. Is fix goes live in p1 or only has to come in future previews?

avatar image Maslobojik Oct 29 '15 at 03:22 PM

will work in 4.99456.5 version =))

(comments are locked)
10|2000 characters needed characters left

I ran into the problem of 3d Widgets just plain and simply not working, not being able to interact with them at all, where they worked ok in 4.8 My setup is that I have 2 computer blueprints, 1 migrated from 4.8, and another newly created blueprint, set up with the exactly same mesh, with a 3d widget component (not copied from 4.8 blueprint, just added to the blueprint with the exact same settings).

When the player clicks on the computer, it gives turns mouse cursor on and changes the interaction to UI and Game.

On the 4.8 blueprint, it works perfectly fine, but on the new 4.9 one, it doesn't work. I even copied the 4.9 widget over to the 4.8 blueprint, removing the 3d widget component from the 4.8 one first, and then it didn't work.

But when I copied the 3d widget from the 4.8 blueprint to the 4.9 blueprint, it worked perfectly.

As for the settings possibly being wrong, I spent hours scratching my head to the point where I got a pen and paper, went through each individual setting and wrote them down, side by side and found they were all identical. I even got another person to triple check it for me just in case I was losing it :P

So my temporary solution I have is to make the 3d widget in 4.8, migrate it to the 4.9 project, and copy the 3d widget component from it for it to work.

more ▼

answered Sep 13 '15 at 03:31 AM

avatar image

Otreum
219 16 26 37

avatar image marsonmao Sep 14 '15 at 09:19 AM

Ok I'm going to check that way, thanks for providing the answer!

avatar image spyro Nov 17 '15 at 03:56 PM

Sounds horrible. :(

avatar image hamsterPL Jan 04 '16 at 04:10 AM

It works ok in 4.10.1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question