x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Version control not syncing assets in editor (perforce)

I am not 100% sure if this was already posted somewhere, if so my apologies.

The issue I am running into is we have a perforce server hosted remotely, everything works fine as does submitting changes via the editor. The problem happens when we try to sync our assets inside of the editor.

When someone else has an asset checked out, I am notified properly (blue check mark with the lock). When the user is done I get the Yellow exclamation mark notifying me that I am not at the latest version for that asset. So I right click the asset and click sync. Everything seems to work great except for the fact that the editor is not actually updating the asset with the changes. To see the actual change I have to do a sync in the editor, and fully restart it to see the changes.

If anyone has some insight to this issue that would be awesome. Or at least a work around for this issue, because this definitely hinders my teams workflow having to constantly restart the editor to see the synced changes.

Product Version: UE 4.10
Tags:
more ▼

asked Dec 10 '15 at 09:02 PM in Bug Reports

avatar image

AM
53 4 5 8

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

Hey AM-

I was able to reproduce the source control issue you described and have entered a bug report (UE-24393) for further investigation.

Cheers

Doug Wilson

more ▼

answered Dec 11 '15 at 08:01 PM

avatar image DFin Jan 02 '16 at 09:22 PM

We also have this bug. This is a major issue for our team. Is there an ETA for a fix?

Edit: A workaround is to "merge" the file -> Select the depot and local file -> Accept Source to get the recent version from depot -> Accept source. Then when promted to checkout cancel. After that you have the recent version from depot opened and you can sync without the need to restart. This is a tiny bit less annoying then restarting.

avatar image Doug E ♦♦ STAFF Jan 04 '16 at 05:56 PM

Hey DFin-

This feature is not currently possible n the engine. While we hope to fix this in the future, there is no timeline for when such a fix will be implemented.

avatar image Dealman Jun 22 '16 at 01:26 AM

Any update on this matter? We still encounter this issue with 4.12.3 along with lots of check-out message spam despite the asset(s) already being checked out.

avatar image Doug E ♦♦ STAFF Jun 22 '16 at 12:43 PM

Hey Dealman-

Unfortunately it is not currently possible to sync referenced assets while the editor is open. We may seek to change that behavior in the future however there is no timeline for when that might happen.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question