x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

"The following modules are missing or built with a different engine version" with a new project

Hi!

I was working on a project in Unreal Engine, and everything went fine until yesterday when I (as usual) switched to Visual Studio to edit some code, but when I switched back to UE window, I noticed that the compile button on the top disappeared. I restarted UE and tried opening my project but all I got was a message box with the following text:

 The following modules are missing or built with a different engine version:

 UE4Editor-StayAlive.dll

 Would you like to rebuild them now?

If I click No nothing happens, if I click Yes, it shows the progress bar and after that another error message

 StayAlive could not be compiled. Try rebuilding from source manually.

Rebuilding the solution in Visual Studio doesn't help either.

I tried creating a new project in UE, but when I try to open it, it fails with the same error. I also reinstalled UE, but it also didn't help. What can I do to fix this problem?

I installed Unreal Engine 4.10.1 from Epic Games Launcher and I also use Visual Studio 2015 Community Edition which was installed when I first created a C++ project. I am able to open Content Examples project or a fresh project which was created from a blueprint template project, but the UE window doesn't have the Compile button on top (I guess because these projects don't have any C++ code).

The version from Help > About: 4.10.1-2791327+++depot+UE4-Releases+4.10

Product Version: UE 4.10
Tags:
more ▼

asked Jan 07 '16 at 03:49 PM in Bug Reports

avatar image

Barzoque
66 1 4 22

avatar image Shadowriver Jan 07 '16 at 04:14 PM

So it successfully build in VS?

avatar image Barzoque Jan 07 '16 at 06:04 PM

Yes, it does.

avatar image 远方来鹏 Jun 29 '16 at 10:03 AM

No sovled the issue till 4.12

avatar image Sean L ♦♦ STAFF Jan 07 '16 at 04:58 PM

Hello,

  • What errors are you seeing when you build the project in Visual Studio?

  • Have you seen this error in the 4.11 preview? If you haven't tried, could you please give that a try?

  • You've been able to successfully work in the engine using VS 2015 up until this error occurred?

avatar image Barzoque Jan 07 '16 at 06:06 PM

Hello,

  • No errors, it builds succesfully.

  • I haven't tried 4.11 preview, I'll try it now.

  • Yes, everything was fine before, the problem appeared yesterday.

avatar image Sean L ♦♦ STAFF Jan 07 '16 at 06:22 PM

Definitely let me know the results of the 4.11 test.

When it builds successfully in Visual Studio, are you then able to open the project?

avatar image Barzoque Jan 07 '16 at 06:40 PM

No, I still get the same error.

avatar image Barzoque Jan 07 '16 at 07:11 PM

Tried it with 4.11, the problem still exists unfortunately. I also tried reinstalling VS 2015, didn't help.

avatar image alfi286 Jan 07 '16 at 09:24 PM

My project has also suddenly broken with the same error. I downloaded 4.10 on Tuesday and created a test c++ project based on the FPS template.

I have come back to it today and it builds fine in VS2015 Pro but then when it launches it says UE4Editor-Helicopter.dll is missing or build with different engine version.

It asks if you want to rebuilt. Press Yes and it says "Helicopter could not be compiled. Try rebuilding from the source manually.

Tried a clean/rebuild all of solution which was successful but still get same error.

avatar image Sean L ♦♦ STAFF Jan 08 '16 at 02:14 PM

Thank you for the information.

Have either of you been able to run the editor in debug mode through Visual Studio?

Also, could you try right-clicking on your .uproject and selecting the Switch Engine Version option? You can choose either 4.10 or 4.11.

avatar image Barzoque Jan 08 '16 at 06:14 PM

When I run the DebugGame Editor configuration is VS (is it what you meant by run the editor in debug mode?), I get the same error, only difference is that the dll name is a little bit different (with -Win64-DebugGame appended).

What do I need to do after switching engine version? Do you mean I need to create the project using 4.10 and then switch it to 4.11 and open it in 4.11?

avatar image Sean L ♦♦ STAFF Jan 08 '16 at 06:17 PM

What you need to do to switch engine version is go into the folder that your project is located in. Then, find the .uproject file, right-click on it, and select Switch Engine Version. A window will appear asking you which version you'd like to switch to. Select either 4.10 or 4.11, and then attempt to open the project again.

avatar image JRV1 Feb 08 '16 at 01:03 AM

Hi, I also started getting this error today. I have added Unreal and MyProject folders to MS Essentials Exclusions but I am still getting the error.

avatar image Sean L ♦♦ STAFF Feb 08 '16 at 01:30 PM

Hello,

Have you attempted the various suggestions offered in this thread? If not, go ahead and try those out and let me know if it works.

Also, there was recently another user who was reporting a similar, if not the same, issue. Take a look at their solution and see if that helps you: https://answers.unrealengine.com/questions/360032/error-in-creating-a-c-project.html

avatar image JRV1 Feb 08 '16 at 05:06 PM

Hey Sean, Yes, I tried those solutions.

I tried uninstalling Unreal 4.10.2 and reinstalling. I received an 'instal' failed error. I restarted, and tried again and it verified, then installed with no error, but I still get the same dll issue.

fwiw - I didn't have VS installed and I wasn't using it until I read up on this issue.

avatar image Sean L ♦♦ STAFF Feb 08 '16 at 07:37 PM

Do you currently have Visual Studio 2015 installed? If so, did you ensure to enable to C++ content? The necessary C++ and Common Tools content does not come with VS by default, and you must manually enable it within the installer in order to get what you need to run the engine.

avatar image JRV1 Feb 09 '16 at 06:03 AM

Yes and yes.

avatar image Sean L ♦♦ STAFF Feb 10 '16 at 01:24 PM

Can you specify exactly which files you created exceptions for with your antivirus? It's possible that a file may have been overlooked.

avatar image JRV1 Feb 10 '16 at 05:15 PM

Under Excluded Files and Locations I've added; H:\GameName H:\Unreal

Under Exluded Processes I've added; H:\Unreal\Epic Games\4.10\Engine\Binaries\Win64\UE4Editor.exe and H:\Unreal\Epic Games\4.8\Engine\Binaries\Win64\UE4Editor.exe

I really appreciate the continued help Sean.

avatar image Sean L ♦♦ STAFF Feb 10 '16 at 06:02 PM

As another test, try turning your antivirus software off and then running the engine. That way you know if for some reason it isn't properly excluding the files, or if there is another issue here.

If it runs successfully, then we will know that there may be other files you need to exclude. If it does not run successfully, we can continue to investigate this issue and get you all set up.

avatar image JRV1 Feb 10 '16 at 06:30 PM

Yeah, that was the first thing I tried.

fwiw - I created a new project this morning and that ran fine - I started to migrate over content, maps and some other assets, and now I get the same error. Looks like it is something in those content files that is causing this.

avatar image Sean L ♦♦ STAFF Feb 10 '16 at 06:37 PM

I was under the impression that you could not open any project. You are only getting this error in one specific project?

avatar image JRV1 Feb 10 '16 at 06:43 PM

If I create a new one, everything runs fine.

I think I found it though - After creating a new project and adding the Vehicle C++ caused this.

Add New > C++ Feature > Vehicle > Add to Project I get an error and when I try to relaunch, the editor spits out the original error.

So I think I have it all sorted now.

So is there any way for me to go back to my original project and remove the vehicle stuffs?

Thanks for you help.

avatar image Sean L ♦♦ STAFF Feb 10 '16 at 07:14 PM

Try going into your project folder->Source->ProjectName->TP_Vehicle and deleting all of the c++ files in there.

After you've done this, go back into the main project folder and right-click the .uproject file and select Generate Visual Studio Project Files.

When I did this, it removed the code classes that were added from the template.

avatar image JRV1 Feb 12 '16 at 04:36 AM

No luck. It's ok. I'm just about back to where I was anyway. Thanks.

avatar image virtual_method Jun 01 '17 at 04:19 PM

For v. 4.15.3 here: What happens here is that I have no permissions. It's asking permissions for Epic Games / engine files (in particular the timestamp for now). Since I cannot change files on C and right clicking on that .uproject file is not an action that I can modify to give Administrator rights, I can't regenerate my project files again. I tried using the Admin account in my system (windows 7) and it didn't work either.
I found it's trying to run BuildTool.exe and it fails having permissions. So I granted permisions to this .exe, and now when I try to regenerate the project files it tells me It couldn't create the process BuildTool.exe.

avatar image franbo Mar 29 '16 at 10:52 PM

Hello! In case anyone else runs into this issue - and for whom the Antivirus exceptions noted in the accepted answer didn't work, I found a fix by deleting the contents of the project's "Intermediate" directory, which allowed the project to compiled successfully; message went away and all was back to normal. Hope that helps! This was in 4.10.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

9 answers: sort voted first

It seems I finally fixed the problem when I added the Unreal Projects folder and folder with the engine (`4.10` and 4.11) to antivirus exceptions. I'm not sure what exactly my antivirus did, but now the editor window opens and I can edit my project. I have Avast in case it helps.

more ▼

answered Jan 08 '16 at 06:33 PM

avatar image

Barzoque
66 1 4 22

avatar image fathergraham Jan 09 '16 at 06:04 PM

I also had this issue until I added my project folder to my Avast "File System Shield" "Exclusions". I noticed that the .dll file was being successfully built by Unreal, then was immediately disappearing, and that was because Avast was deleting the .dll file.

avatar image virtual_method Jun 01 '17 at 04:17 PM

This can happen also due to permissions. Since it's strying to modify files under C:/.../engine files. So this is not the answer in my case.

avatar image flaviorangel Feb 25 '19 at 01:24 PM

I added the folders to antivirus exceptions, but still the error is still occurring. Did you do anything else after that?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I ran into the same issue, and in the end what worked for me was right clicking on the uproject file, selecting "generate visual studio project files." From there I opened the newly created ProjectName.sln file with visual studio, and selected build. I let the project rebuild and then reopened, and voila, all was good again. Hope this helps someone else in my predicament.

more ▼

answered Aug 24 '16 at 01:37 AM

avatar image

TheMayor
113 5 8 18

avatar image suheti Oct 12 '16 at 02:02 PM

This worked for me! Thank you so much!

avatar image virtual_method Jun 01 '17 at 04:17 PM

Unless your system doesn't grant you permissions to change the timestamp file (and probably more of them) under C:

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I've had the same issue. I created a new project and copied all files from the earlier project to the new one except the files "saved" and "[project name].uproject". Then I started "[new project name].uproject" and it worked. Thank God! I'm so relieved.

more ▼

answered May 03 '16 at 04:35 PM

avatar image

DominikSchwenk
41 1 2 4

avatar image nati8boy Jun 04 '16 at 07:06 AM

I had the same problem and your solution worked perfectly for me. Thank you! I was really unsure of how I was going to get my file working again. Phew!

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I also had this problem but it was due to the fact I used a previous project to build off of. I needed to right click my .uproject file and edit the name like so:

alt text

more ▼

answered Nov 04 '17 at 08:34 PM

avatar image

Katianie
151 27 21 30

avatar image amisner2k Oct 02 '18 at 05:09 AM

Thank you! This was the solution for me as well. I was playing around, getting my feet wet with C++ but I made the mistake of trying to create a C++ class in the editor without first having the C++ toolchain for Visual Studio installed first. I got errors in my Output Log telling me that I needed the C++ toolchain installed first. So I did that but then...

This caused all sorts of weird anomalies while trying to debug and edit code, etc. So I desperately wanted to start over with the C++ thing now that I had the toolchain properly pre-installed. I didn't need to keep any of the classes I created, so I deleted all the source files in the Source and Binaries folder, but then I got the "following modules are missing" popup when trying to launch the editor, which brought me here.

Removing the entire "Modules": [ {...} ] section for the .uproject file did the trick for me. Removing it, along with the Source, Intermediate and Binary folders, successfully got my project back to a working, pre-C++ state.

avatar image hassannnnnn Apr 26 '19 at 07:52 PM

Thanks for the solution. I also had the same issue with this, I tried to create a new C++ class but it ended up breaking my project so I deleted the "Modules", Saved and Binaries and now its working again.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

You might wanna disable any plugins that your project currently have by editing your .uproject file with a notepad

more ▼

answered Oct 25 '16 at 09:11 AM

avatar image

ObamaPls
6 1 1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I solved this by going into my project folder, then into intermediate folder, then deleting the Source folder inside there.

After that, I right clicked on the .uproject file, and selected the "Generate Visual studio files" option. It successfully built the files, then I double clicked the .uproject file, and then it says ""The following modules are missing or built with a different engine version...", select Yes, and it will build files for a minute.

After that the project opens and works great.

more ▼

answered Apr 13 '17 at 06:58 PM

avatar image

DevinStewart
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Hi, in my case the issue was that my compilation was not creating the file UE4Editor-projectname.dll anymore.

This is because I was missing this line in \Source\MyProjectEditor.Target.cs:

ExtraModuleNames.Add("MyProject");

Without this line the compilation succeed, but UE4Editor-projectname.dll is not created.

more ▼

answered Feb 21 '18 at 04:18 PM

avatar image

Talad
121 5 8 13

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

I had compiler errors when I last exited UE4/VS that seem to have been causing this issue. My solution was:

1) Open the Visual Studio Solution file in the project directory 2) Build the solution, and fix any compiler errors that appear 3) Once the build is complete, close VS and reopen the project from UE4

more ▼

answered Mar 27 '18 at 06:30 PM

avatar image

Gkleinereva
11 7 3

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

Had a similar issue with UE4Editor-UnreadEd.dll Deleted it from the UE4/engine/binaries/win64 folder and then compiled the UE4 project in VS and it rebuilt the dll and its fine now.

The initial cause was a power outage in the middle of a full rebuild. You might also want to compile your game project again just to be sure its up to date after that. If its another file thats causing the error for you, try deleting it and recompiling. (make a backup of it just in case)

more ▼

answered Jul 01 '19 at 10:11 PM

avatar image

Gitchimo
1

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question