x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Problems Packaging for Android

I've been following this youtube video (https://www.youtube.com/watch?v=PXGe-O_PWVI) and when I go to package to all android types, I don't know my android package, I receive this error message (attachment). Any help would be appreciated...

Phone: Samsung Galaxy Note 5 Build: 5.1.1link text

Product Version: UE 4.10
Tags:
error.txt (163.6 kB)
more ▼

asked Mar 20 '16 at 03:04 AM in Packaging & Deployment

avatar image

Sammm91621
31 2 5

avatar image MiKom Mar 20 '16 at 02:40 PM

Some tool in the C#/Java/UBT spaghetti probably doesn't like the long path to the project. It exceeds 256 characters and some ancient windows APIs don't like paths that long.

Try moving the project to some location with shorter path.

If the girl lets you do this...

avatar image Sammm91621 Mar 20 '16 at 05:21 PM

She did haha~ I changed the location of the project and even tried renaming it and it seems I have the same error still. link text

error2.txt (143.2 kB)
avatar image Rudy Q ♦♦ STAFF Mar 23 '16 at 08:39 PM

Hello Sammm91621,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?

  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?

  3. Have you been able to package any projects successfully?

  4. Could you provide screen shots of any settings that you have set?

avatar image Sammm91621 Mar 25 '16 at 02:26 AM
  1. Here is the set up of settings before I load a blank page.alt text Here is how I packaged the project (I'm not sure what my actual build is) alt text Here are screenshots of the settings I have for the build.alt textalt textalt text, also my settings follow the youtube video in my original post. ( https://www.youtube.com/watch?v=PXGe-O_PWVI ), I also recieved the same errors after trying to package it.

avatar image Sammm91621 Mar 25 '16 at 02:26 AM

[link text][6] [6]: /storage/temp/83737-error_on_clean.txt

error_on_clean.txt (220.5 kB)
avatar image Sammm91621 Mar 25 '16 at 03:30 AM

Part 2- I followed what was installed on the video , starting with https://www.visualstudio.com/ Microsoft Visual Studio. Then I installed the OEM for my phone, http://www.samsung.com/us/support/downloads Phone USB/ OEM Drivers. ![alt text][1]. Then, https://developer.nvidia.com/gameworksdownload#?dn=codeworks-for-android-1r4 Nvidia SDK , then https://developer.nvidia.com/gameworksdownload#?dn=nsight-visual-studio-edition-5-0-0 Nvidia Nsight. I installed all the plugins for all of visual studio and for sdk, tried to update sdk from eclipse and it said i didnt have any even though sdk did. Then just see the setup of the video for how I set everything up. [1]: /storage/temp/83770-phone+oem.png Part 3- No so far I haven't. Part 4- I put this in part 1 on accident~

phone oem.png (103.6 kB)
avatar image Rudy Q ♦♦ STAFF Mar 28 '16 at 07:01 PM

Hello Sammm91621,

Does it make a difference if you package out using Android (ETC2)?

avatar image Sammm91621 Apr 01 '16 at 01:22 AM

It seems to be the same error. Whatever RunUAT.bat is, isn't running in like the last line. Could that have something to do with it? [1]: /storage/temp/84675-error_on_clean_2.txt

avatar image Sammm91621 Apr 06 '16 at 06:57 AM

Bump for help

avatar image Rudy Q ♦♦ STAFF Apr 11 '16 at 02:16 PM

Hello Sammm91621,

Would it be possible for you to provide a copy of the example project that you are using to reproduce this issue on our your end so that I could take a closer look and run a few tests?

avatar image Sammm91621 Apr 11 '16 at 03:27 PM

https://drive.google.com/folderview?id=0B2N7TZql8x0PcXJwNFotU3JjM28&usp=sharing

Here is a link to the whole file; I've shared on google drive. Also Unreal 4.11 was released as well and has better VR support so maybe that will help as well. Thank you for your help.

avatar image Rudy Q ♦♦ STAFF Apr 15 '16 at 06:30 PM

Hello Sammm91621,

I downloaded the project provided and was able to package it out without any issues. I understand that you have gone through a tutorial, however could you double check that you have everything set up correctly but going over the information provided in the link below?

Link: https://docs.unrealengine.com/latest/INT/Platforms/Android/GettingStarted/index.html

avatar image Sammm91621 Apr 17 '16 at 03:56 AM

Hi Rudy, I followed the steps on here to step four (deployment) and everything seemed to be going okay, I had 39 different nvidia things installed on my phone, and then I got an unknown error listed here and this error on a clean re-try here.. I'm not really sure what made the error happen.

avatar image Rudy Q ♦♦ STAFF Apr 19 '16 at 08:29 PM

Hello Sammm91621,

What did you set the SDK API level to? Try setting it to android-19 and NDK API level to android-19. Also make sure the Android SDK path is set to your android-sdk-windows directory.

avatar image Sammm91621 Apr 20 '16 at 01:25 PM

Hi Rudy, I had both of the API on latest. But the android-sdk-windows directory was fine. ![Here][1] is a picture of my settings. [1]: /storage/temp/87646-settings.png

Also while packaging this line appears in yellow "LogStats:Warning: MetaData mismatch. Did you assign a stat to two groups? New //STATGROUP_Threads//FLauncherTask///Thread_18f4_0///####STATCAT_Advanced#### old //STATGROUP_Threads//FLauncherTask///Thread_219c_0///####STATCAT_Advanced####"

Edit: I got it to port to my phone as shown in step 4. Still not sure how/ if it will package.

settings.png (65.2 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Rudy and MiKom, Thank you for all your help. I just got the build to package out and be install-able. Just one last question for you guys, would there be any other changes for VR support that i would need to make in the settings? If not you have answered all of my questions and done an amazing job. Once again, thank you guys.

-Sammm91621

more ▼

answered Apr 20 '16 at 01:55 PM

avatar image

Sammm91621
31 2 5

avatar image Rudy Q ♦♦ STAFF Apr 25 '16 at 01:38 PM

Hello Sammm91621,

I am happy to hear that you have things working on your end. From what I can tell looking at your settings, you should have everything setup correctly. If you have any further issue please feel free to create a new post with any information you have. I will be accepting your last comment as the answer to this question. If you could you provide more information on what it is you may have done to get things working for you, this would be helpful to any other users who are having the same issue.

Make it a great day

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question