x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Game editor unable to load after coding error

The editor was not able to be loaded after some code errors. the offensive codes were: MyParticles-> CreateDefaultSubobject(TEXT("Fire")); // "->" static ConstructorHelpers::FObjectFinder MyParticlesSystem(TEXT("ParticleSystem'/Game/StarterContent/Particles/P_Fire.P_Fire")); // "missing ' "

amended codes were: MyParticles= CreateDefaultSubobject(TEXT("Fire")); static ConstructorHelpers::FObjectFinder MyParticlesSystem(TEXT("ParticleSystem'/Game/StarterContent/Particles/P_Fire.P_Fire'"));

I had loaded the project thru vs2015 by clicking UProj_platform.sln as i couldnt load the game project thru the unreal launcher without immediately exiting (with crash errors). From there i I have removed/amended the code errors and ran the code by "local windows debugger" (solution was in DebugGame Editor mode). It compiled without errors and successfully loaded the unreal game editor with the game running with no errors. However, that was in VS DebugGame editor mode and wasnt not able to be compiled in the Unreal game editor environment. After existing both vs2015 and unreal game editor, i had tried loading the project thru unreal launcher but was exited with a crash report. Please help. This happens for both 4.10 or 4.11 preview. As attached is the log file.

link text

Product Version: UE 4.10
Tags:
more ▼

asked Mar 26 '16 at 05:50 PM in Bug Reports

avatar image

pickersZ
70 7 10 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I have seen this link which has another issue, but part of the solution solved my problem. link text

to fix this, you will need:

  1. Double click your project_file.sln in the base dir of the project folder.

  2. Amend the offending code by commenting them out or amending them in the the vs2015.

  3. Save the code without debugging and exit vs2015.

  4. Delete "Binaries" folder in the project root folder.

  5. Click on the project in the unreal launcher. It will prompt "rebuild or something", just proceed with it.

  6. The game editor will show up as usual without exiting with error codes.

The above assumed that error code was eliminated and therefore the game editor should open as usual.

more ▼

answered Mar 27 '16 at 06:15 PM

avatar image

pickersZ
70 7 10 11

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question