x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

2D rendering artifacts when moving camera

Hello everyone, I have recently started developing a top-down 2D game (in the style of the old "Zelda"-games) and ran into the problem that all the images become very blurry when trying to move the camera. It looks as if there were "waves" moving through my screen (comparable to the effect you would see on older monitors I suppose). Ontop of that, sometimes a line of pixels is simply missing or has the wrong texture. I have made sure that all the texture groups are set to "2D Pixels (unfiltered)" and post-processing is turned off, but the artifacts are still there. I suspect that the artifacts originate from the fact that 1cm equals 1pixel when rendering, but the camera is not always being moved by an integer value, leaving it on something like 10.5cm on the x-axis, thereby everything is rendered 10.5 pixels to the left and due to rounding it creates the artifacts described above. The easiest way to avoid this will obviously be manually rounding down the coordinates of the camera after each update (EDIT: Scratch that, it doesn't even work), but I wonder if there is a more elegant solution to that. Thanks in advance!

EDIT: Just to give everyone an idea what I am talking about: alt text I recorded this with "epic" graphics settings, but you get the same effect with minimum settings. The same happens if I disable the code in the tick event, except that there will be more and slightly different artifacts if I do.

Product Version: UE 4.11
Tags:
more ▼

asked May 21 '16 at 11:48 PM in Rendering

avatar image

BrightC
31 3 5 8

avatar image haruna Jun 03 '16 at 08:35 AM

Go to your tile's texture settings. Double click the texture. On the right, there's a details panel. Look for the "Texture" category. If the triangle below sRGB is facing down, please click on it.

You should see 2 options: X-axis Tiling Method Y-axis Tiling Method

Are these set to CLAMP? They're set to wrap by default. Setting them to clamp has gotten rid of garbage on the edges of sprites for me before.

avatar image BrightC Jun 03 '16 at 02:44 PM

Unfortunately that did not seem to change anything. Thanks for the suggestion though.

avatar image falola Dec 26 '16 at 11:09 AM

I am experiencing the same thing, have you solved this yet?

avatar image Noros Feb 01 '17 at 08:36 AM

Encountering this same issue on build 4.14.3. I've tried to disable all motion blur and post processing effects. I'm noticing visual artifacts where pixels in a tilemap will shift/blur during motion then return to normal once the camera has stopped moving. Not sure if this is a camera related issue or related to the texture. My game screen is 1280x720, with a camera of orthographic width = 640.

Any help would be much appreciated.

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

You have to right click on your tileset and pick "Condition Tile Sheet Texture". It's a feature that's easy to miss and I also haven't found anywhere in the documentation. This should fix the seams that appear when moving.

Why the "waves" happen, I don't know either. The same thing happens on my project and it's really game breaking. I already asked about it here with video and example project: https://answers.unrealengine.com/questions/519204/paper-2d-tilemap-stutter-in-standalone-or-packaged.html

But sadly nobody wants to take a look at it.

more ▼

answered Nov 07 '16 at 09:18 AM

avatar image

jonaspincky
26 1 3 8

(comments are locked)
10|2000 characters needed characters left

Disable Motion Blur post processing.... considering game you making you could disable post processing all toghther

more ▼

answered May 21 '16 at 11:56 PM

avatar image

Shadowriver
33.9k 916 164 1093

avatar image BrightC May 22 '16 at 12:06 AM

I'm afraid that's not it. I just disabled all of the post-processing settings in "Project Settings/Rendering" as well as in the camera itself, and the artifacts are still there. Appreciate the suggestion though.

(comments are locked)
10|2000 characters needed characters left
more ▼

answered Sep 29 '16 at 11:45 PM

avatar image

JDel
1 1

avatar image nonchip Jun 08 '18 at 04:06 AM

that would actually increase artifacts.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question