x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Compile Blueprint Crashes editor; (Virtual functions table is invalid)

Hi Everyone,

I am using Unreal Engine 4.17.1 (both the GitHub source and the launcher versions). I am running into an issue that has me stumped. In the project that I am working on there is an actor class that we use as a parent to many other classes. This file has been in our project awhile and has had no issues. Recently we tried to change and compile it but this ends up crashing the editor. When we looked deeper into the issue, it looks like the event is triggered by a conditional statement in the UE4 source code. The statement is as follows:

 if (*(void**)this == nullptr)
 {
     UE_LOG(LogUObjectBase, Error, TEXT("Virtual functions table is invalid."));
     return false;
 }

Does anyone know what could cause this, and how we could fix it?

Thanks!

Product Version: UE 4.17
Tags:
more ▼

asked Sep 06 '17 at 05:17 PM in Using UE4

avatar image

wojton
11 2 6

avatar image brianm2smith Sep 06 '17 at 05:39 PM

I have been debugging this problem as well. If I start with my application in 4.16.2 i can compile all of the blueprints no issue. When I upgrade to 4.17.1 I can't compile some of my actor classes. The only difference i can see is the get root component node (1) changed over to a K2 get root component node (2).

  1. GetRootComponent

  2. K2 Get Root
    Component

I would just switch back but we have done development in 4.17.1 and it is saying that my level is not backwards compatible.

grc.png (15.8 kB)
avatar image brianm2smith Sep 06 '17 at 05:58 PM

Trying to switch back to version 4.16.2 i get this message: Failed to open map file. This is most likely because the map was saved with a newer version of the engine.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

I found a post, that solved my issue with a work around. [Thank you, Burnz]

you have set [/Script/UnrealEd.BlueprintEditorProjectSettings] bUseCompilationManager=False

Here is the link to the original post: https://answers.unrealengine.com/questions/700562/editor-crashing-417-when-compiling-blueprints-ue-4.html

If any one figures out the original issue, causing this to happen, or if there is another fix, please let me know.

more ▼

answered Sep 11 '17 at 12:31 PM

avatar image

wojton
11 2 6

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question