x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Can't host a server using Steam. "SteamSockets: binding to port 7777 failed"

Hello.

My game works well without the Steam API, I can host a game with open map?listen and join over a network with open ip however I can't seem to get it working with the Steam API.

I'm pretty sure it's going wrong here, when I type open map?listen:

 [2014.07.18-13.01.38:486][340]LogInit: SteamSockets: Socket queue 131072 / 131072
 [2014.07.18-13.01.38:487][340]LogNet:Warning: Network Failure: GameNetDriver[NetDriverListenFailure]: SteamSockets: binding to port 7777 
 
 failed (0)
 [2014.07.18-13.01.38:487][340]LogNet: NetworkFailure: NetDriverListenFailure, Error: 'SteamSockets: binding to port 7777 failed (0)'
 [2014.07.18-13.01.38:487][340]LogNet: DestroyNamedNetDriver IpNetDriver_0 [GameNetDriver]
 [2014.07.18-13.01.38:487][340]LogExit: GameNetDriver IpNetDriver_0 shut down
 [2014.07.18-13.01.38:487][340]LogWorld: Failed to listen: SteamSockets: binding to port 7777 failed (0)
 [2014.07.18-13.01.38:488][340]LogNet:Error: LoadMap: failed to Listen(/Game/Maps/Dev?listen)

I forwarded the 7777 port but it still doesn't work.

Larger log attached, any help would be appreciated!

log.txt

Product Version: Not Selected
Tags:
log.txt (15.7 kB)
more ▼

asked Jul 18 '14 at 01:24 PM in Packaging & Deployment

avatar image

Acren
460 46 49 70

avatar image joessu Mar 10 '16 at 05:27 AM

I know this is an old post but i am getting this error still, and i followed several different tutorials with different INI settings, and also the epic documentation.

 [2016.03.10-05.24.10:266][407]LogNet:Warning: Failed to init net driver ListenURL: /Game/Maps/Lobby?listen: SteamSockets: binding to port 7777 failed (0)
 [2016.03.10-05.24.10:266][407]LogNet:Warning: Network Failure: GameNetDriver[NetDriverListenFailure]: SteamSockets: binding to port 7777 failed (0)
 [2016.03.10-05.24.10:266][407]LogNet: NetworkFailure: NetDriverListenFailure, Error: 'SteamSockets: binding to port 7777 failed (0)'
 [2016.03.10-05.24.10:266][407]LogWorld: Failed to listen: SteamSockets: binding to port 7777 failed (0)
 [2016.03.10-05.24.10:266][407]LogNet:Error: LoadMap: failed to Listen(/Game/Maps/Lobby?listen)
 [2016.03.10-05.24.10:266][407]LogWorld: Bringing World /Game/Maps/Lobby.Lobby up for play (max tick rate 0) at 2016.03.09-21.24.10
 [2016.03.10-05.24.10:266][407]LogWorld: Bringing up level for play took: 0.000284
avatar image Samantha Sutton ♦♦ STAFF Mar 10 '16 at 10:09 PM

Joessu,

Did you set up your DefaultEngine.ini as Ryan suggested in the answer below?

(comments are locked)
10|2000 characters needed characters left

3 answers: sort voted first

Ok, it looks like the documentation I linked to in my previous answer is incorrect as of this posting - sorry about that, I'll make sure it gets updated.

The section headings in DefaultEngine.ini should be modified as follows from the documentation:

Change [Engine.GameEngine] to [/Script/Engine.GameEngine]

Change [OnlineSubsystemSteam.SteamNetDriver] to [/Script/OnlineSubsystemSteam.SteamNetDriver]

more ▼

answered Jul 22 '14 at 06:57 PM

avatar image

Ryan Gerleve STAFF
1.1k 25 12 49

avatar image Acren Jul 23 '14 at 08:40 AM

Thanks! That did the trick for the binding.

 [2014.07.23-08.04.04:349][613]LogNet:Display: SteamNetDriver_0 bound to port 7777
 [2014.07.23-08.04.04:349][613]LogNet: GameNetDriver SteamNetDriver_0 IpNetDriver listening on port 7777

However now I am getting this:

https://answers.unrealengine.com/questions/73472/cant-host-a-server-using-steam-steam-no-game-prese.html

(comments are locked)
10|2000 characters needed characters left

Hi Acren,

Let's make sure the basics are covered - double-check that everything is set up according the Steam online subsystem documentation. From the log it looks like the game is trying to use the generic IP net driver instead of the Steam net driver, which means it may not be configured correctly in your DefaultEngine.ini file. The above documentation link has an example of how to set this up.

more ▼

answered Jul 18 '14 at 04:19 PM

avatar image

Ryan Gerleve STAFF
1.1k 25 12 49

avatar image Acren Jul 19 '14 at 12:09 AM

Hi Ryan.

Yes, I have the DLLs installed in Engine/Binaries.

I have the v130 sdk, but I have to rename the folder to Steamv129a instead as it will complain LogOnline:Warning: STEAM: Steam DLLs not present or failed to load! otherwise.

With the folder name as Steamv129a, the editor log says LogOnline:Warning: STEAM: Steam API disabled!, which apparently is to be expected as the Steam Online Subsystem doesn't activate in the editor.

I also have the following in my DefaultEngine.ini.

 [Engine.GameEngine]
 +NetDriverDefinitions=(DefName="GameNetDriver",DriverClassName="OnlineSubsystemSteam.SteamNetDriver",DriverClassNameFallback="OnlineSubsystem.IpNetDriver")
  
 [OnlineSubsystem]
 DefaultPlatformService=Steam
  
 [OnlineSubsystemSteam]
 bEnabled=true
 SteamDevAppId=480
  
 [OnlineSubsystemSteam.SteamNetDriver]
 NetConnectionClassName="OnlineSubsystemSteam.SteamNetConnection"

I also loaded the module in the build file.

Is there anything else required? Thanks.

Also worth noting that the game DOES show the overlay and tell all my friends that I am playing Spacewar.

avatar image Ryan Gerleve STAFF Jul 21 '14 at 11:24 PM

Hi Acren,

As far as I know, we haven't tested with other versions of the Steam SDK. It's worth trying the actual v129a SDK, if possible.

If you are seeing the "Steam API disabled!" message in the same run when you try to open the listen server, try running the server from a non-editor build.

avatar image Acren Jul 22 '14 at 01:42 AM

Thanks for the suggestion, I tried the v129a SDK but it yielded the same results as the v130.

The "Steam API disabled" only happens in the editor, but trying with standalone or packaged game results in the "SteamSockets: binding to port 7777 failed" as mentioned in the OP.

(comments are locked)
10|2000 characters needed characters left

Had the same bug. UE4.15

Fix was int the DefaultEngine.ini change [/Script/Engine.Engine] to [/Script/Engine.GameEngine]

(Slightly different variant of the above fix.)

more ▼

answered May 15 '17 at 04:19 AM

avatar image

SND R Keene
933 29 118 112

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question