Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Office Holiday

Epic Games' offices will be on holiday from June 22nd to July 7th. During this period support will be limited. Our offices will reopen on Monday, July 8th. 

Why are maps not being packaged?

I have made a menu for my game that uses the 'Open Level' node that goes to various mini-games. This works in the editor, but when I package and launch my game on Android or iOS the menu buttons don't work. When running the 'stat levels' command only the Default Game Map shows up. The other maps aren't there.

This seems like it may be a 4.3 bug. Even Swing Ninja in 4.3 shows the same results when packaging as well.

Product Version: Not Selected
more ▼

asked Aug 08 '14 at 02:38 PM in Packaging & Deployment

avatar image

32 6 7 11

avatar image Moss Aug 08 '14 at 03:21 PM

Could you post how did you setup your packaging in UnrealFrontend?

avatar image explosivo Aug 08 '14 at 03:34 PM

alt text

These are my packaging settings currently, although I've tried every other combination.

capture.png (82.9 kB)
(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

What I refer to is using the UnrealFrontend to cook all our maps, by default it only cooks the default map, you can either change your ini settings to alwasy cook certain maps or use UnrealFrontend to select which maps to cook.

Just open UnrealFrontend and go to the 'Game Launcher' tab (the others could be also ok, this one just has the full path) and then the Advanced section. From there you specify how to build, cook, package and launch your game. In the cooking section you then select the maps you would like to cook apart from the default map.

This is an example of how to package an HTML5 build (similar on every platform): https://answers.unrealengine.com/questions/80447/html5-build-issue.html

more ▼

answered Aug 08 '14 at 03:42 PM

avatar image

6.4k 127 98 606

avatar image Tim Hobson ♦♦ STAFF Aug 08 '14 at 03:49 PM
avatar image explosivo Aug 08 '14 at 04:36 PM

Thanks a lot! This helped a ton

avatar image Moss Aug 08 '14 at 04:38 PM

I think you have to re-accept the answer :D Strange system :D

avatar image DaveBerg Oct 07 '14 at 01:18 PM

@Explosivo. Did you manage to get "open level" to work in packaged game? Choosing levels in Frontend is not doing it for my game. As in your case all works fine in the editor.

(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question