x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Dynamic Navmesh Different in Packaged than Editor

I've run into a new problem in 4.21. Having some serious difficulties generating navigation meshes on dynamic terrain. The biggest problem is that after some tuning things seem to work fine in the editor but when packaged, there are seams in the navmesh that prevent AI from crossing. Here's a picture

These are my navigation settings

[/Script/NavigationSystem.RecastNavMesh] RuntimeGeneration=Dynamic AgentMaxSlope=46.000000 TileSizeUU=1000.000000 AgentMaxStepHeight=64.000000 bFixedTilePoolSize=True bForceRebuildOnLoad=True bDoFullyAsyncNavDataGathering=True

[/Script/NavigationSystem.NavigationSystemV1] CrowdManagerClass=Class'/Script/AIModule.CrowdManager' bAutoCreateNavigationData=True bSpawnNavDataInNavBoundsLevel=False bAllowClientSideNavigation=True bShouldDiscardSubLevelNavData=True bTickWhilePaused=False bInitialBuildingLocked=False bSkipAgentHeightCheckWhenPickingNavData=False DataGatheringMode=Lazy bGenerateNavigationOnlyAroundNavigationInvokers=True ActiveTilesUpdateInterval=1.000000 +SupportedAgents=(Name="Common",Color=(B=0,G=255,R=140,A=164),DefaultQueryExtent=(X=50.000000,Y=50.000000,Z=250.000000),NavigationDataClassName=None,AgentRadius=35.000000,AgentHeight=144.000000,AgentStepHeight=-1.000000,NavWalkingSearchHeightScale=0.500000,PreferredNavData=None,bCanCrouch=False,bCanJump=True,bCanWalk=True,bCanSwim=False,bCanFly=False) DirtyAreasUpdateFreq=60.000000

This problem is new to 4.21. Everything was working in 4.20. I did notice now that without setting to fully async, NavigationInvokers stopped working as well.

Product Version: UE 4.21
Tags:
more ▼

asked Nov 17 '18 at 02:49 PM in Bug Reports

avatar image

Xilverback
136 2 7 9

avatar image Xilverback Nov 17 '18 at 06:26 PM

I confirmed that the seams are along the Tile boundaries. Increasing the TileSize changes the seams accordingly.

avatar image Xilverback Nov 17 '18 at 08:41 PM

Tried Switching to Chunky Monotone as discussed in this thread... Thread

No luck. Again, things seem to work in the editor but not in the packaged build.

avatar image Xilverback Nov 17 '18 at 09:29 PM

Also, I've already reported this through your the Bug Tracker. I am aware that you recently switched to a new bug tracking method. What I'm looking for here is new/unknown configuration requirements for 4.21. That could address this.

avatar image Xilverback Nov 20 '18 at 04:22 PM

Tweaking the Cell Size to 32 x 21 and the AgentRadius to 35 made the problem go away but now having problems with AI using doors, stairs etc.

avatar image jimsnomis Nov 20 '18 at 04:40 PM

Just to confim I'm seeing similar issues using navigation invokers and dynamic navmesh. They worked fine in 4.20. In 4.21 the recastnavmesh serialization has some uninitialized variables in it when loaded (NaN etc.). This led to some infinite loops in the tile calculations and seems to be intermittent, sometimes works fine other times not.

avatar image Jeff A ♦♦ STAFF Nov 20 '18 at 10:15 PM

Hello,

We've recently made a switch to a new bug reporting method using a more structured form. Please visit the link below for more details and report the issue using the new Bug Submission Form. Feel free to continue to use this thread for community discussion around the issue.

https://epicsupport.force.com/unrealengine/s/

Thanks

avatar image Xilverback Nov 21 '18 at 12:02 AM

Did that first :)

avatar image blobdole Nov 24 '18 at 02:14 AM

Do you have a link to the issue? We are having the same issue and I would like to vote on it and track it.

avatar image Xilverback Nov 24 '18 at 06:17 AM

I'd love to share a link with you but all I got was this...

Thank you for your bug submission. We will be investigating your case and follow up if more information is needed or when a ticket is created. You can track the latest UE4 issues at https://issues.unrealengine.com/

avatar image blobdole Nov 24 '18 at 10:33 AM

I made a test project that demonstrates this issue.

https://drive.google.com/open?id=1ZBNv-nj8o1ow5FkGmnTx6z8AkDpi3PiD

How it looks in editor: alt text

How it looks when packaged: alt text

avatar image Positivity Nov 29 '18 at 05:51 PM

I have Exact problem :( Fix Probobly will be only in 4.21.1 , Only how long we must wait. For now now Packaged Testing.

avatar image Xilverback Nov 30 '18 at 03:00 PM

Got this email from Epic...

It appears you might not have received my previous reply to this issue. I am glad to say this issue is fixed in our latest internal build. I'm unsure when it will be officially released but you are using any of our Source Builds you can grab it from the Master Branch on GitHub. This was fixed in CL-4567513

avatar image Positivity Nov 30 '18 at 06:21 PM

Awesome, now just we need to wait till Launcher version got Updated. 4.21.1 , They fixed this Bug and Bug where level Streeming doesn't regenerate Dynamic nav mesh on Mobile.

avatar image blobdole Dec 04 '18 at 10:09 PM

Confirmed NOT repaired in 4.21.1

=(

avatar image Positivity Dec 08 '18 at 10:32 AM

Yes, It is not Fixed, however, Support told us that it is Fixed in Master Branch of UE4 .. so I m confused from where does 4.21.1 comes if not the master branch .. but ok I'm Downloading Master Branch will update if master Branch really fixes this Issue.

avatar image eudrea Dec 13 '18 at 01:23 AM

Does Master Branch fixes the issue? (we are having this issue as well and there's no way to go around it, we might just have to build from source)

avatar image jimsnomis Dec 08 '18 at 02:19 PM

Has anyone located the commit for this on the master branch? I can't find any comments with CL-4567513.

avatar image Positivity Dec 08 '18 at 02:22 PM

You can read in Comments what Support Answered to a person who made bug report .. https://answers.unrealengine.com/questions/848562/view.html

avatar image jimsnomis Dec 08 '18 at 02:26 PM

Thanks though there's no reference in the comments to the code/commit for the fix.

avatar image Nonlin Jan 02 '19 at 07:39 PM

I updated my project from 4.20 to 4.21 and it seems now as though the dynamic navigation fails to generate correctly in both editor and packaged builds but more consistently with packaged builds.

I don't get the lines but just the nav mesh doesn't generate entirely consistently at all in 4.21. Anyone else have an issue like this?

avatar image jimsnomis Jan 02 '19 at 09:07 PM

@Nonlin yep that's the issue I have. Waiting for a fix from Epic.

(comments are locked)
10|2000 characters needed characters left

1 answer: sort voted first

I've had some luck tuning the CellSize and TileSizeUU settings. Seems more stable when TileSizeUU is divisible by CellSize. On a larger map, I used TileSizeUU=3072 and CellSize=32 and worked in the build.

more ▼

answered Jan 02 '19 at 07:55 PM

avatar image

Xilverback
136 2 7 9

avatar image eudrea Jan 03 '19 at 09:31 PM

The issue is fixed in 4.22 (which is the Master branch from git) but for now people need to build from source to have it.

avatar image PONY DRUNK PONY Jan 11 '19 at 07:56 PM

I'm having similar issue using 4.21.1. I have a VR scene when in the editor I'm standing on the ground. When I package the project the ground is at my waist. Not sure if this is a related problem or the same.

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question