x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

[4.10] IOS launch failure

Hi, I am trying learning how to launch a game on an iphone and am having a few problems with deployment. I am using the vehicle advanced template with no modifications. The certificate and provision have been properly set up and are valid. When I launch the game I get an unknown error and have attached the output log. I noticed that it says "Failed to connect to bundle". I'm basically stuck and I'm not sure where to go from here.

Few things to know:

  • itunes 12.3.2.35

  • iphone 5 version link text9.2

  • UE4 4.10

  • PC(Windows 10)

  • advanced vehicle template(as is)

Product Version: UE 4.10
Tags:
output_log.txt (742.9 kB)
more ▼

asked Dec 27 '15 at 06:06 PM in Packaging & Deployment

avatar image

Darvos
63 4 6 8

avatar image Samantha Sutton ♦♦ STAFF Dec 29 '15 at 06:15 PM

Darvos,

These are the following errors found within your project output logs:

 LogPlayLevel: DeploymentServer: Failed to connect to bundle 'com.EnemySpawn.examplegame' with Unknown error 0xE80000B7
 LogPlayLevel: DeploymentServer: Error: Failed to connect to bundle 'com.EnemySpawn.examplegame'
 
 LogPlayLevel: IPhonePackager: IPP ERROR: Application exception: System.Security.Cryptography.CryptographicException: Invalid provider type specified.

It looks like your signing isn't working correctly for your iOS project. You may want to make sure that you've properly set up your Certificate and Provision like the guide suggests.

avatar image Darvos Dec 30 '15 at 04:48 AM

Hi, thank you for the reply. I have followed the instructions provided in the guide and I believe that the provision and certificate are set up properly. However, I do wonder if the error is caused by the iphonepackager application. When importing the provision, certificate, and keypair, I get no check marks(green or yellow). Also, in the iphonepackager app, there is a message:

"Could not find file 'C:\Program Files\Epic Games\4.10\Engine\Build\IOS\UE4Game-Info.plist'."

I was under the impression that 4.10 doesn't need a manual info.plist because UE4 generates it for me. Do you have any insight on this? Thanks

avatar image Samantha Sutton ♦♦ STAFF Dec 31 '15 at 06:48 PM

Did you utilize the import function within the editor before using IPP? This is an older post but it may be what you are running into: AnswerHub Link

avatar image Darvos Jan 01 '16 at 05:11 PM

I have tried both ways several times and I keep having the same issue. At this point I'm wondering if this is a bug because I have followed the instructions and keep getting the same error. Not to sure where to go from here. Any advice?

(comments are locked)
10|2000 characters needed characters left
Viewable by all users

1 answer: sort voted first

Darvos,

Code iOS projects on Binary (Epic Games Launcher version of the Engine) will not package or launch on iOS devices. Please make sure that you are using a Mac in order to package your iOS project. You may also want to check that your XCode is up to date and that you're not using a beta version.

I also browsed through Jira and found UE-16236 which is a bug stating that Windows code projects fail to package on iOS devices from GitHub.

Thanks!

more ▼

answered Jan 04 '16 at 04:02 PM

avatar image Darvos Jan 04 '16 at 07:39 PM

The project I have uses only blueprints, no code. Also, I don't have access to a mac. Does this mean I cannot develop IOS games on my PC?

avatar image Samantha Sutton ♦♦ STAFF Jan 11 '16 at 05:59 PM

Have you tried adding your BUNDLE ID to your certificate in Bundle Identifier? You can find these areas in Project Settings > Platform - iOS.

Replace YOURCOMPANY with your BUNDLEID.

avatar image Darvos Jan 15 '16 at 01:39 AM

Hi, so after trying to figure this out using every tutorial and piece of information I can find, I am still left stuck. I know it has to do with the way I'm naming things. I will create a video of the steps that I'm taking to set up and maybe that will better help solve this mess. Thanks

avatar image Samantha Sutton ♦♦ STAFF Jan 15 '16 at 06:53 PM

Could you show me some screenshots of the naming conventions so I can try to help?

Thank you!

avatar image Darvos Jan 16 '16 at 05:38 PM

I know this is wrong, but here is an example so you may better guide me. Please tell me what I am suppose to put in each box. Thanks and sorry to be such a pain.

image1.png (122.3 kB)
image2.png (55.3 kB)
avatar image Samantha Sutton ♦♦ STAFF Jan 19 '16 at 08:09 PM

Hey Darvos,

iOS Settings

As you can see in the image above, you simply need to put your project name in the Bundle Display Name and the Bundle Name. In the Bundle Identifier, you'll need to put com.YOURCOMPANY.PROJECTNAME.

iossettings.jpg (38.1 kB)
avatar image Darvos Jan 19 '16 at 08:17 PM

Right. Now I have a individual account, no company. What would be my company name?

avatar image Samantha Sutton ♦♦ STAFF Jan 20 '16 at 05:42 PM

Your bundle ID is going to include AgonyID. So it should be com.YOURCOMPANY.AgonyID.

Have you tried deleting your DerivedDataCache, Intermediate and Saved folders from your project?

Upload the newer logs, thank you!

avatar image Darvos Jan 25 '16 at 02:45 AM

So I experimented a little a got has no success or progress. Here is a image of what I have. I changed it from AgonyID to just Agony. Any ideas as to what I may try?

image3.png (113.8 kB)
avatar image Xen0genic Jan 25 '16 at 09:02 AM

Darvos,

Sign in to Apple Developer (developer.apple.com) and go to your Certificates, Identifiers & Profiles. Go to Identifiers, and then you should have the app ID you created for your game. It will have its name on the left, and the ID on the right will be what you put in "Bundle Identifier."

If you haven't set any of that up, then you will need to join apple developer before you can get this ID etc. Here is the UE4 documentation that I used to help, since I just did all this too: https://docs.unrealengine.com/latest/INT/Platforms/iOS/QuickStart/5/index.html

avatar image Darvos Jan 25 '16 at 06:14 PM

Hi, if you scroll up you can see I have a Apple developer account and have matched the bundle ID to App ID. The very top shows my log. The latest image is me following Samantha's instructions to put com.YOURCOMPANY.Agony. Showing that it is invalid when I put that and the only way to make is valid is if I were to put that exact string as my App ID on the Apple website. Which also does not work. Is there by chance a phone number to where I can call someone for tech support? Thanks

avatar image Samantha Sutton ♦♦ STAFF Jan 28 '16 at 08:11 PM

You most likely have a specific mobile provision of the form com.companyname.game and you have not specified that exact name in the App Bundle Identifier in the Project settings. Set the Bundle Identifier to the exact same name as the mobile provision identifier and it should work.

We do not have technical support via the telephone. AnswerHub and Forums are where you can receive assistance.

Thanks!

avatar image Darvos Jul 28 '16 at 01:03 AM

I finally did resolve this by putting com.epicgames.agony and waiting for version 4.12. Thanks

avatar image gnuchev Mar 08 '17 at 02:02 PM

Thanks, putting com.YOURCOMPANY.PROJECTNAME. in a Bundle Identifier field solved issue for me (I haven't put PROJECTNAME initially)

avatar image bariscavusoglu Jan 04 '18 at 02:51 PM

Hi I'm also in the same boat,

I can't launch my game on my iPhone.

My MacBook Pro version Is 10.13.2

I am using Unreal Engine 4.18.2

I have an iPhone 7 with version 11.2.1

I'm using xCode Version 9.2.

Please help:(

Here are the lines with errors;

 LogCook: Display: Cooking /Engine/EditorResources/LightIcons/S_LightError -> /Users/bariscavusoglu/Documents/Unreal Projects/LocationTrial148/Saved/EditorCooked/IOS/Engine/Content/EditorResources/LightIcons/S_LightError.uasset
 LogSavePackage: Async saving from memory to '/Users/bariscavusoglu/Documents/Unreal Projects/LocationTrial148/Saved/EditorCooked/IOS/Engine/Content/EditorResources/LightIcons/S_LightError.uasset'
 LogSavePackage: Display: Finished SavePackage /Users/bariscavusoglu/Documents/Unreal Projects/LocationTrial148/Saved/EditorCooked/IOS/Engine/Content/EditorResources/LightIcons/S_LightError.uasset
 LogPlayLevel:   Failed to connect to bundle 'com.bariscavusoglu.BarisCavusogluIOSProfile' with Unknown error 0xE80000B7
 LogPlayLevel:   [DD]  ... Error: Failed to connect to bundle 'com.bariscavusoglu.BarisCavusogluIOSProfile'
 LogPlayLevel:   /Users/Shared/Epic Games/UE_4.18/Engine/Binaries/IOS/Payload/UE4Game.app: unknown error -1=ffffffffffffffff
 LogPlayLevel: ERROR: CodeSign Failed
 LogPlayLevel: AutomationTool exiting with ExitCode=32 (Error_FailedToCodeSign)
 LogPlayLevel: RunUAT ERROR: AutomationTool was unable to run successfully.
 PackagingResults: Error: Launch failed! Failed to Code Sign
(comments are locked)
10|2000 characters needed characters left
Viewable by all users
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question