x

Search in
Sort by:

Question Status:

Search help

  • Simple searches use one or more words. Separate the words with spaces (cat dog) to search cat,dog or both. Separate the words with plus signs (cat +dog) to search for items that may contain cat but must contain dog.
  • You can further refine your search on the search results page, where you can search by keywords, author, topic. These can be combined with each other. Examples
    • cat dog --matches anything with cat,dog or both
    • cat +dog --searches for cat +dog where dog is a mandatory term
    • cat -dog -- searches for cat excluding any result containing dog
    • [cats] —will restrict your search to results with topic named "cats"
    • [cats] [dogs] —will restrict your search to results with both topics, "cats", and "dogs"

Android Build Failed

I downloaded the source code of UE4 and build it with a configuration of Win64 Development Editor. Then I followed the steps of Android Quick Start but failed to build a version for Android. In the log, it said "PackagingResults:Error: Error Launch failed! Unknown Error". How can I fix it?link text

Product Version: UE 4.11
Tags:
log.txt (788.2 kB)
more ▼

asked May 09 '16 at 07:53 AM in Using UE4

avatar image

Isatin
85 5 7 126

avatar image Samantha Sutton ♦♦ STAFF May 11 '16 at 03:00 PM

Hey Isatin,

Could you please show me a screenshot of your Android SDK? Are you able to package a newly created template, or do you receive the same errors?

Thanks!

avatar image Isatin May 11 '16 at 08:17 PM

Hi Samantha,

Thanks for your reply. Did you mean my folder of Android SDK or Android SDK Manager? Anyway, attached you can find both. I just followed the instructions in Anroid Quick Start and built a template project of ThirdPerson on a virtual device of Nexus 5 but failed. There are some warnings in the log but I am not sure if they were related to the build failure.alt text

avatar image Samantha Sutton ♦♦ STAFF May 13 '16 at 07:35 PM

lsatin,

Thanks for providing me these screenshots. I didn't specify your Android SDK settings from within the editor and that's my fault - my apologies. Looking at your folders though, I can tell that you've installed AndroidWorks, so as long as it's set up within the engine correctly - you shouldn't have any problems.

Here is an example of how mine looks:

Android SDK

Thanks! :D

androidsdk.png (50.9 kB)
avatar image Isatin May 14 '16 at 01:57 AM

Hi Samantha,

I didn't notice that settings, but after I set up those folders, I still got the same error. However, I noticed on another page of settings, Platfroms - Android, there is a warning saying "Project is not configured for the Android Platform." But when I pushed the "Configure Now" button, an error message just popped up, "Could not overwrite project properties file". Does it have something to do with my build failure? alt textalt text

avatar image Samantha Sutton ♦♦ STAFF May 16 '16 at 02:48 PM

Does the same error "Could not overwrite Project Properties file." occur in a new template created, or does it only occur in your project? Have you tried deleting your Intermediate, Saved and Config files from your project folder? If so, were you able to press the "Configure Now" button? That does need to be selected in order to successfully package onto Android.

Looking forward to hearing back, thanks! :)

avatar image Isatin May 17 '16 at 07:46 PM

I tired what you said but still got the same error message, "Could not overwrite Project Properties file." However, I found that the Build folder and its subfolders were all read-only. Even if I tried to remove their attributes of read-only in Windows Explorer, they would be set back to read-only automatically, which was quite weird to me. Does it have something to do with the project properties file? Where should be the project properties file?

By the way, I was just trying to learn how to build Android projects in UE4 and I just followed Android Quick Start and created projects from the ThirdPerson template. I modified nothing except the project settings to build the projects.

(comments are locked)
10|2000 characters needed characters left

2 answers: sort voted first

Later on I downloaded the installer and installed UE4 instead of compiling one in VS. Then I tried to create an Android project and this time the "Configure Now" button worked without the error "Could not overwrite Project Properties file." So it looks like there was something wrong with the version I built from the source code. Anyway, thanks for your help again.

more ▼

answered May 18 '16 at 05:46 AM

avatar image

Isatin
85 5 7 126

avatar image Samantha Sutton ♦♦ STAFF May 18 '16 at 03:52 PM

Did you resolve your issue? It sounds now that perhaps the Visual Studio version you're using isn't the right one. Are you on VS 2015?

Thank you for giving updates!

avatar image Isatin May 18 '16 at 04:17 PM

Yes, I'm using VS2015 and the source code of UE4 I used to compile was the zip from GitHub. I didn't modify the source code, so I don't know what's the difference between the one I built and the one from the installer.

avatar image Andy Chang Dec 13 '16 at 09:28 PM

I got this error and resolved it by building UE4 for Android | Development in Visual Studio, and then relaunching the editor.

avatar image sealfoss Mar 23 '18 at 03:56 PM

Can you elaborate on this option you set? I can't find anything about building UE4 specifically for android development in Visual Studio, but I am getting the same error.

avatar image Streliteela Apr 25 '18 at 09:21 AM

@Andy Chang I have hit the same issue. Could you provide more detailed information about that "by building UE4 for Android | Development in Visual Studio "? Really appreciate your help :-)

avatar image Streliteela Apr 25 '18 at 02:05 PM

@Andy Chang I think I've got what you mean. But there is no Android option :- ( Look forward to your reply. alt text

platform.png (5.2 kB)
avatar image Andy Chang Apr 25 '18 at 03:12 PM

My list has Android as the first option. Do you have Codeworks installed?

avatar image Streliteela Apr 26 '18 at 02:58 AM

I tried to download and install CodeWorks for many times, but always failed. Luckily, I found someone had uploaded the folders . So I just copied the NVPACK folder and pointed the Editor to the install locations. P.S. the version of UE that I use is 4.18.3

avatar image Streliteela Apr 27 '18 at 09:30 AM

Hi @Andy Chang , I start a new thread to desribe my problems in detail. Could you give me more help? Thanks :)

avatar image Streliteela Apr 28 '18 at 03:03 AM

Finally, I fixed it by run Setup.bat -include=Android instead of Setup.bat. Because the command Setup.bat, by default, only downloads the dependencies for the current platform. ([TUTORIAL] How to use Setup.bat and how to reduce download size][1])

[1]: https://forums.unrealengine.com/development-discussion/engine-source-github/25735-tutorial-how-to-use-setup-bat-and-how-to-reduce-download-size

(comments are locked)
10|2000 characters needed characters left

Hey, I had the same problem building a new project on Mac. I was able to get it to work by simply creating the file in question (it didn't exist). I did that by running the 'touch project.properties' command in the Build\Android directory of my project. Hope that helps!

more ▼

answered Feb 27 '17 at 09:18 PM

avatar image

wryday
11 1

(comments are locked)
10|2000 characters needed characters left
Your answer
toggle preview:

Up to 5 attachments (including images) can be used with a maximum of 5.2 MB each and 5.2 MB total.

Follow this question

Once you sign in you will be able to subscribe for any updates here

Answers to this question